my post is gone, but my problem with Android is not...

my post is gone, but my problem with Android is not … can anyone help me and restore my post? thanks

log.txt

I have partially solved the problem . First of all, I reinstalled the Android-ndk-r6 eliminating the backup copy. Should never use a backup copy, generates a whole series of problems. After this I managed to compile the libraries openframework successfully. But not everything went well. I have three errors that I do not know how to solve: riferit have to file errno.h setjmp.h glu.h and why I have these mistakes now?
another thing I noticed: when you create an external tool to run the applicatione, must be observed:

Working Directory: $ {} project_loc

not

Working Directory: $ {project \ _loc}

and that in

Arguments: AndroidInstall PROJECT \ _path = $ {} project_loc

not

Arguments: AndroidInstall PROJECT \ _path = $ {project \ _loc}

there is a discrepancy in the online help through the images and the written text.

Also when i run Android Install, it fails ask me to update the project : then i run in the folder for example :

[quote/home/walter/android-sdk-linux/tools/android update project --target android-8 --path /home/walter/openframeworks007/apps/androidExamples/androidAudioExample][/quote]
i have deleted the buil.xml file and run aagin the update project but nothing changes. It is related to the issues before?
thanks
googling i found my post that was disappeared: http://forum.openframeworks.cc/t/android-not-compiling-after-reinstallation/8820/0

p.s :i’m working now on Ubuntustudio 11.04 maybe there is some differences between Ubuntu 11.04?

i solved partially these errors reinstalling the Android SDK, I think it’s not related to Ubuntustudio .Now my project with example succesfull build but… i have again issues . when i launch Android Install to run the app they ask my to update:

if[ -d “bin/data” ]; then \
mkdir -p res/raw; \
rm res/raw/androidpolygonexampleresources.zip; \
cd bin/data; \
zip -r …/…/res/raw/androidpolygonexampleresources.zip *; \
cd …/…; \
fi
if [ -f obj/ ]; then rm obj/; fi
#touch AndroidManifest.xml
/home/walter/android-sdk-linux_x86/tools/android update project --target android-8 --path
Error: Missing argument for flag --path.

Usage:
android [global options] update project [action options]
Global options:
-h --help : Help on a specific command.
-v --verbose : Verbose mode, shows errors, warnings and all messages.
-s --silent : Silent mode, shows errors only.

Action “update project”:
Updates an Android project (must already have an AndroidManifest.xml).
Options:
-l --library : Directory of an Android library to add, relative to this
project’s directory.
-p --path : The project’s directory. [required]
-n --name : Project name.
-t --target : Target ID to set for the project.
-s --subprojects: Also updates any projects in sub-folders, such as test
projects.
make: *** [AndroidInstall] Error 1

i follow

walter@walter-VGN-AR51E:~/openframeworks007/apps/androidExamples/androidPolygonExample$ /home/walter/android-sdk-linux_x86/tools/android update project --target android-8 --path /home/walter/openframeworks007/apps/androidExamples/androidPolygonExample
Updated project.properties
Updated local.properties
No project name specified, using Activity name ‘OFActivity’.
If you wish to change it, edit the first line of build.xml.
Added file /home/walter/openframeworks007/apps/androidExamples/androidPolygonExample/build.xml
Updated file /home/walter/openframeworks007/apps/androidExamples/androidPolygonExample/proguard.cfg

but this don’t change anything my app not run. Someone can explane me what exactly i have to do?
also i notice that i have warnings about opengles like this:

Description Resource Path Location Type
libcutils.so, needed by /home/walter/android-ndk-r6/platforms/android-8/arch-arm//usr/lib/libGLESv1_CM.so, not found (try using -rpath or -rpath-link) androidAssimpExample C/C++ Problem

thanks

most of my problems are solved but now i receive this error:

BUILD FAILED
/home/walter/android-sdk-linux_x86/tools/ant/build.xml:485: Invalid file: /home/walter/openframeworks007/addons/ofxAndroid/ofAndroidLib/build.xml

Total time: 0 seconds
make: *** [AndroidInstall] Error 1

i know that i can use this command:

android create project --target 2 --path /home/walter/openframeworks007/addons/ofxAndroid/ofAndroidLib

but tis is not enough, how i set up :

–activity <your_activity_name> \
–name <your_project_name> \
–package <your_package_namespace>

??
thanks

this make me a new build.xml :

android create project --name ofAndroidLib --target 1 --package “cc.openframeworks.cc” --path /home/walter/openframeworks007/addons/ofxAndroid/ofAndroidLib --activity “OFActivity”

but when i launch Android install:

BUILD SUCCESSFUL
Total time: 2 seconds
cp bin/OFActivity-debug.apk bin/androidPolygonExample.apk
cp: cannot stat `bin/OFActivity-debug.apk’: No such file or directory
make: *** [AndroidInstall] Error 1

help me please!

what’s the command you’re using to produce that error message, and what is the directory you’re running the command in?

Regarding --target, 1 is probably a bad idea since that points to the very earliest version of Android. It’s probably better to do --target android-8, which is version 2.2.

I got the error about the missing build.xml file for ofAndroidLib too. You can also do ‘android update project --path PATH_HERE’.