MSVCP140.dll and VCRUNTIME140.dll are missing


#1

When trying to run an oF application in a computer that does not have Visual Studio installed.

It seems the problem can be solved by downloading the dlls from microsoft website:
https://www.microsoft.com/en-us/download/details.aspx?id=48145

but I would prefer that oF apps do not throw this error.

Any ideas?
J


Problems making stand-alone visual studio OF application
#2

BTW I’m on stable branch.

Also, tried to change Project settings:

C/C++/Code Generation/Runtime Library

from /MD to /MT but boost library is not compiled for this configuration, so it is missing the file:

libboost_filesystem-vc140-mt-s-1_58


#3

this is always like that when you have an application that is built using visual studio. the only solution that i know apart from installing the runtime manually is creating an installer for the application using something like: https://msdn.microsoft.com/en-us/library/cc766795.aspx but it’s something i haven’t done in a long whie so no idea of the specifics


#4

How about compiling boost with /MT settings?
I guess if i do that the entire project will include the runtime libraries statically in the binary so it wont ask for dlls anymore right?


#5

yeah didn’t knew that option but it might work, i can imagine though that other libraries wil have the same problem.


#6

Oh I see, this means recompiling all of libraries.
Would be great to do it through Apothecary.
Ok Thank you!


#7

Hola @jordi y @arturo !

I’ve gone through this issues several times and it is so annoying. Although, I haven’t tried out either MSYS2 or QT. Arturo, when using any of these two on Windows, would I get rid of the need for these DLLs?

best!


#8

with msys2 you can use make copy_dlls and it’ll copy all the needed dlls from the system to the bin folder


#9

Hi all!
I’ve try the msys2 export but I’m getting the following missing dll:

… libgraphite2.dll is missing from …

Fixed by copying just this 2 dlls from “C:\msys64\mingw32\bin” in the bin project folder

  • libgraphite2.dll
  • libgomp-1.dll

#10

ah thanks, this dependencies probably change over time, i’ll add the new libraries to the makefiles


#11

Users of windows 10 one day must face this error which is vcruntime140.dll is missing which happen at any time. Normally when we installed any recent windows 10 update then bug of that update causes this error. 2nd case when a specific dll file of VCRuntime140.dll is missing in your computer. According to me 3D DriveGuard is the best option to get the solution of this error.


#12

My problem was resolved by downloading msvcp140.dll manually. Use this resource for vcruntime140.dll. It sounds like your problem is pretty much the same thing. Just make sure that you choose correct version of dll according to you system.


#13

Yes. You are right. This issue can be solved by installing the dll manually. The main question on this thread was about how to build OF so that it wouldn’t throw this error. It seems we still haven’t gotten there quite yet. Thanks for the Link.


#14

Sometimes what happened that is the both MSVCP140.dll and VCRUNTIME140.dll are missing at the same time but now the time is to get rid of all the issues to check missing MSVCP140.dll and you will be definitely got the solution.


#15

yikes…

this is a good reason to still use older versions of openframeworks with code blocks and manually fork features that are necessary to your project…

I never understood why we abandoned codeblocks the first place, for unicode?