Missing [FreeImage.dll


I’ve have various projects with OpenFrameworks v0.9.8 and VS2015 on windows, but today I decided to upgrade to VS2017 and OF v0.10
I installed VC17, added the openFrameworks plugin but any apps I try to compile (either mine or the examples) the process fails with an error msg about missing FreeImage.dll. I assume more are missing but it stop at the first.
Looking at the v0.9.8 version, there is an export directory at the root of OF, but the same doesn’t exist in v0.10
I tried to manually copy it from one to another, but it didn’t help. I can manually add those to the bin folder of each app, some work, others not.

Am I missing something?
I can see there is libs\FreeImage, but how can I make VS to copy and link those?

Thank you

You may have luck upgrading your projects with the project generator first.

I tried the project generator multiple times with various example projects, but no .dll files are copied to the bin folder of each project.
Is there maybe anyone using VS2017 that can confirm that those files are copied in there?

thanks again

I had the exact same error when I used Win32 release, but when I switched to x64 release everything was working fine (my setup is OF v0.10, VS2017, Win8.1).

yep, that’s it.
Really feels like a beginners problem!

thank you

If someone is still on Win32 release and receiving this error. Try to download FreeImage.dll from dll library. Here is a manual how to do this.

can anybody open an issue on github about this? the dlls should be copied in both 32 or 64 bits after compiling if needed

I am not sure if this is an OF problem directly. I had issues with the download libs script recently (Windows version 1803 download libs and robocopy SOLVED) after a windows update. Somehow my copy of robocopy.exe was corrupted.

Correct me if I am wrong but the post build copy in windows is also handled by robocopy.exe. I just reinstalled windows and with the same download of OF I am able to compile apps in all permutations of debug and release 64 and 32 and all Dlls are copied correctly (on the same download of OF), whereas before no DLLs would copy. I think the issue is something going wrong with windows. I could not work out a way to fix it, I found an old installer that contained robocopy, this worked for the download libs script in the githib version of OF, but not for the post build copies. After much scrambling re-installing was the only way I could fix this.

mmh ok, yes some other people have reported having issues with robocopy as well i think, is anybody else seeing something related to robocopy in the build output?

Don’t see any errors on the output when I build for Win32. Just the error of the missing .dll when it’s trying to launch the application.

1>------ Build started: Project: openframeworksLib, Configuration: Debug Win32 ------
1>d:\mystuff\ch3\dev\visual studio 2017\of_v0.10.0_vs2017_release\libs\openframeworks\communication\ofarduino.cpp(1526): warning C4333: '>>': right shift by too large amount, data loss
1>openframeworksLib.vcxproj -> D:\myStuff\ch3\dev\Visual studio 2017\of_v0.10.0_vs2017_release\libs\openFrameworksCompiled\project\vs\..\..\lib\vs\Win32\openframeworksLib_debug.lib
1>Done building project "openframeworksLib.vcxproj".
2>------ Build started: Project: periodicSignalsExample, Configuration: Debug Win32 ------
2>   Creating library bin\periodicSignalsExample_debug.lib and object bin\periodicSignalsExample_debug.exp
2>periodicSignalsExample.vcxproj -> D:\myStuff\ch3\dev\Visual studio 2017\of_v0.10.0_vs2017_release\examples\math\periodicSignalsExample\bin\periodicSignalsExample_debug.exe
========== Build: 2 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

Actually I am having the same problem with the last nightly and OF 2017.

I’m having this problem currently in VS2019 with the FreeImage.Standard nuget package. I’ve tried targeting x64 specifically, but it doesn’t work. I can manually copy the DLL into the bin folder, and that fixes it, but seems less than ideal.

Hello. Same problem here. I can only compile for X64, not x86. I’m using windows 10 and the last OF version.
The error message tell freeImage.dll is missing. If I copy that file to the bin folder of the project then it ask me for the fmod.dll too. Then, being copied both into the bin folder it works fine, but I found out that if I change the architecture target to x64, then compile, and then back again to x86, and compiling again, the problem reappears