Missing 64-bit support

Hey! silly question im trying to submit an app but my binary is invalid. I get his email.

Missing 64-bit support - Beginning on February 1, 2015 new iOS apps submitted to the App Store must include 64-bit support and be built with the iOS 8 SDK. Beginning June 1, 2015 app updates will also need to follow the same requirements. To enable 64-bit in your project, we recommend using the default Xcode build setting of “Standard architectures” to build a single binary with both 32-bit and 64-bit code.

How can i fix this. Im using xcode 6.1


Current state of the art for ios 64 bit is here: https://github.com/openframeworks/openFrameworks/pull/3651

@danoli3 and @abrahamavnisan have it working at least.

1 Like

Thanks! i successfully run the example know i replace the code with my app code the includes opencv and storyboard and i get this any idea?

Unfortunately that’s one I don’t recognize … @danoli3 have you seen that before?

1 Like

OpenCV currently is the only Apothecary Script I haven’t really audited yet. Still on the fail list:

Storyboards should be fine with the new windowing code for 0.9.
It’ll just be the OpenCV lib being not 64 bit (arm64), as well as not being libc++.

1 Like

Ok! thanks a lot! when can i expect the fix ?
I really need to submit the app to itunes connect for a client :confused:

i also need this so eager ,i have not updated my app two months.please help help help help!!! can’t thank u any more! @danoli3

@danoli3 hey! how is going? when can we expect the fix for openCV?

I may have some time next week to have a look at it and get it working.

cool! thanks.

oh,no,two weeks have passed…waiting

I would also need this please.

Guys let’s no rush people that work for free, see if you can help with the current issues and that will surely make things faster.


I wish i could help! but is out of my knowledge anyways i been trying to understand

Hello all,

I wasn’t aware of this 64 bit requirement so i finished a new app in the last days and was trying to submit it when i got to this brick wall.
I tried to compile from the 0.9 version but somehow i can’t figure out how to make it work.
It’s quite a “simple” app and I’m not using any openCV so i believe it would be possible to compile with the current state of 0.9, am i right?

If so, could someone shed some light on how to compile from the current state of the 0.9 vs?

Thanks in advance!
all the very best

Download this https://github.com/openframeworks/openFrameworks/pull/3651 and read the instructions.

:sob: waiting…


Hello! @danoli3 did you saw my message?

1 Like

Need some help!
how can i run the apothecary builds ?