Make failed with exit status 2


This is sort of a repost of the beginners post of Kevin:

Running windows 10, OF 0.9.0, android-ndk-r10e, Android Studio.

I am trying to build the androidEmptyExample. I have followed the tutorial, added dependecies, set the android sdk versions and gradle version. Receive an error when trying to ‘sync project with gradle files’: “make failed with exit status 2”.

Log gives me more specifically:
pathto\of\android-ndk-r10e\toolchains\arm-linux-androideabi-4.9\prebuilt\windows-x86_64\lib\gcc\arm-linux-androideabi\4.9\include\stdint.h:9:26: fatal error: stdint.h: No such file or directory

The file exist but I am a lost on how to fix this, does anyone have similar errors and solved them?

Thank you,

I think still better to use eclipse did you try it?

No, haven’t tried it yet.

My recent switch to windows was experimental enough, but if Android Studio will not coorperate I will eventually try Eclipse.

one thiung to check is that you don’t have spaces in the path to openframeworks (not only in your project). also can you post the full output of the error?

make[1]: Leaving directory ‘/c/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworksCompiled/project’
make: Leaving directory ‘/c/Users/jochem/Documents/OF/of_v0.9.0_android_release/examples/android/androidEmptyExample’
In file included from c:/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworks/utils/ofConstants.h:2:0,
from c:/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworks/math/ofVec2f.h:5,
from c:/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworks/math/ofVec3f.h:3,
from c:/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworks/3d/ofMesh.h:7,
from c:/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworks/gl/ofVboMesh.h:3,
from c:/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworks/3d/of3dPrimitives.h:3,
from c:/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworks/3d/of3dPrimitives.cpp:9:
c:\users\jochem\documents\of\android-ndk-r10e\toolchains\arm-linux-androideabi-4.9\prebuilt\windows-x86_64\lib\gcc\arm-linux-androideabi\4.9\include\stdint.h:9:26: fatal error: stdint.h: No such file or directory

include_next <stdint.h>


compilation terminated.
make[2]: *** [/c/Users/jochem/Documents/OF/of_v0.9.0_android_release/libs/openFrameworksCompiled/lib/android/obj/armv7/Debug/libs/openFrameworks/3d/of3dPrimitives.o] Error 1
make[1]: *** [Debug] Error 2
make: *** [Debug] Error 2

FAILURE: Build failed with an exception.

  • Where:
    Build file ‘C:\Users\jochem\Documents\OF\of_v0.9.0_android_release\libs\openFrameworksCompiled\project\android\build.gradle’ line: 157

  • What went wrong:
    A problem occurred evaluating project ‘:openFrameworksProject’.
    > make failed with exit status 2

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


Total time: 17.042 secs

There are no spaces in the path.

Hi clwnr,

Did you ever find a solution to this issue? I am trying to build androidEmptyExample using Android Studio 2.2.2 and I keep getting the same Description “make failed with exit status 2” error.

Any help would be greatly appreciated.



Hey Paulo,
No, I didnt. I think at the time i switched to mac, since i got more
support for that in my direct surrounding, but then work came along that
stopped the hobby project.
Sorry cant be of any help, good luck.

In case anyone runs into the same issue, I solved it by replacing all the MINGW32_NT occurrences in the file by MSYS_NT-10.0

Its because of gradle mismatch version. check your gradle version with OF gradle version.
even i had same problem now it solved.

How can I do this?
Can we fix the of git master examples that it’s like downloading android Studio, add the ndk with Tools > Android > SDK Manager and then compile it?

in openFrameworks/libs/openFrameworksCompiled/project/android
classpath '' is this the gradle or the android sdk version? Where can I find the of gradle Version?