Major trouble with github openframeworks

hiya guys,

love the new forum look.
im having some major troubles with running anything from the github oF, and i dont know why. im on mac 10.9 with xcode 5.0.2

i cant even run the projectGenerator to build a new project at all. i do run into an error i try to build under all SDK 10.6 to 10.9. this is to do with ofTypes.h, saying that the - ‘tr1/memory’ file not found. this errors pops up all around the other examples and workings, i just cant get anything to work with the github oF.
is there a way around this, would i have to completely uninstall oF or xcode and start again?
i just want to have the ability to make some android/ipad stuff, along with making other things, but just want the full oF.

anyhow, the website download of oF works fine, just the github one is playing up. though i have used it before, ive just recently gotten back into it.
great if someone could help

lewis six


the tr1 error is happening I’m pretty sure because of the SDK target. Can you try making sure the SDK is set to 10.8 and not 10.9?

see for example here – you should see 10.8 set for the base SDK.

(see also this issue on github –

same issue, it has this tr1/memory error. and this happens on ALL base sdks that i have, which are 10.6 through to 10.9

does the OF library compile? (and what sdk is it set to?)

it does not compile no. plus it starts on 10.9, but i do change it if it has trouble compiling with any other sdk

the website version of oF works perfectly, im using it right now. so dont know what could be up with it

any ideas to what could be doing this?
should i reinstall xcode?

i would have thought since the website version works, that the github would be nearly the same

I just tried a fresh pull of github on osx 10.9, xcode 5.0.2… the OF lib compiled fine, but I did get the tr1 error with the project generator. Once I set the sdk (which was set to “none”) it compiled fine. the OF lib compiled ok with 10.9 or 10.8 as the sdk.

Can you check what your c++ flags are for compiling?

maybe something get messed up with this? (it’s another thing besides SDK that I think can cause issues with tr1 / includes)

1 Like

it was on these settings beforehand

but changed it what you said to, but still the same. also kept the os to 10.9, when that didnt work i changed it to 10.8. but no.

is this an xcode issue, or even my computer?
im guessing that, but would think id need to start again with the installs, but thats just harbouring a guess. i will try that though and see what happens. need to clean my machine a bit anyway

HA ZAAA!!! i got it working again.
i completely took off xcode, took out ANYTHING that had ‘developer’ on it, also xcode. just started again, popped xcode in my folder for code stuff [i keep programs in special folders, like music and office stuff, its OCD ;)]. got hold of another download of the github file, changed the sdk to 10.8 [as 10.9 does not play nice with it], and… it works.

so just a reinstall of xcode and start again and it was all done, lovely. it runs… thanks for the help though zach, it does mean a lot.
heres a screenshot to show it built :wink:

1 Like