macOS 4K capture with magewell USB Capture SDI 4K Plus


#1

I have been using the magewell HD and 4k with a 4K Marshall camera successfully, when set to output HD resolution.
Now I’m testing the videoGrabber to capture 4k but the grabber sets itself to 2560x1440 even though

    vidGrabber.initGrabber(4096, 2160);
**[notice ] Device: 0: USB Capture SDI 4K+ #2**
**[notice ] 0: USB Capture SDI 4K+ #2**
**[warning] ofAvFoundationGrabber: requested width and height aren't supported. Setting capture size to closest match: 2560 by 1440**

Does anyone have experience with capturing 4K over this USB device?


#2

Just in case, did you use the magewell application to set the device settings, maybe you need to set it to 4k there for it to be recognised.


#3

thanks for the reply.

yes I tried their software and set resolution to 4096x2160.
but the capture formate seems to get set by either quicktime or my OF app. but both don’t offer 4k.




#4

I have an interest in this for an upcoming project, did you get anywhere? Could you make it capture at UHD instead of the DCI format, so 3840*2160, I see UHD as a standard capture preset in avfoundation: https://developer.apple.com/documentation/avfoundation/avcapturesessionpreset?language=objc_2


#5

Thanks for the tip. But it did not help.
OF still says 2560 1440 is the max res.
Nor quicktime or OF show a proper feed.


#6

It now works. All I changed was using a SDI cable that is sold as 4K capable. Not sure if that is really why it works now or if doing a reset on the SDI 4K unit helped.


#7

SDI at 4k 30p is 6g and at 60p is 12g, that is a lot of data and for sure with a 1.5g (1080i60) or 3g 1080p60 cable it would not have worked. No idea why it did not give you the resolution though, maybe the capture box checks the impedance of the cable?