Mac os monterey m1

Hi, I just made the mistake of updating my MacBook to Monterey and Xcode to 13.1. And now I cannot run any of my sketches. I did change the Build System options and now I get this kind of error:

error: unknown target CPU ‘vortex’
note: valid target CPU values are: i386, i486, winchip-c6, winchip2, c3, i586, pentium, pentium-mmx, pentiumpro, i686, pentium2, pentium3, pentium3m, pentium-m, c3-2, yonah, pentium4, pentium4m, prescott, nocona, core2, penryn, bonnell, atom, silvermont, slm, goldmont, goldmont-plus, tremont, nehalem, corei7, westmere, sandybridge, corei7-avx, ivybridge, core-avx-i, haswell, core-avx2, broadwell, skylake, skylake-avx512, skx, cascadelake, cooperlake, cannonlake, icelake-client, icelake-server, tigerlake, sapphirerapids, alderlake, knl, knm, lakemont, k6, k6-2, k6-3, athlon, athlon-tbird, athlon-xp, athlon-mp, athlon-4, k8, athlon64, athlon-fx, opteron, k8-sse3, athlon64-sse3, opteron-sse3, amdfam10, barcelona, btver1, btver2, bdver1, bdver2, bdver3, bdver4, znver1, znver2, znver3, x86-64, geode

/Users/mirkofebbo/Library/Developer/Xcode/DerivedData/myPioneeringSketch-albsjgyieknetkhiaecvqgmruovi/Build/Intermediates.noindex/ warning: Could not read serialized diagnostics file: error(“Failed to open diagnostics file”) (in target ‘myPioneeringSketch’ from project ‘myPioneeringSketch’)

Command CompileC failed with a nonzero exit code

Fixed it! I just needed to update to the latest Openframework version!


Glad to hear!
Was just about to upgrade from macOS 11.0 to troubleshoot :slight_smile:

Good to confirm it all works in Xcode 13.1


1 Like

Hi Theo,

Thank you for the follow up I am happy I could help a bit! Also, thank you for all your help in the forums I always see you there supporting the community!



I need to compile of 0.9.4 with Xcode 13 in Monterey on a m1 MacBook Pro. I know, this is for sure not the best thing to do, but I am willing to give it a try. After a couple of other problems that I managed to solve so far, I am getting now the exact same error as Mirko.

Is there any way to fix this?

Many thanks,