Lots of problems with Microsoft Visual Studio

Hi,

I’m having a lot of trouble with compiling projects with Visual Studio.
I have used the 2005 version running OF 0.05 (on XP) all the time and everything
working fine until I discovered that the compiled programs can’t run on
other computers (On the other computers the source SideBySide complains
about Resolved Partial Assembly fail for Microsoft VC80.DebugCRT)

These kinds of problems I found out was related to the Visual Studio
2005 edition, but it was promised to be fixed in SP1, which I downloaded.

Now the problems get even worse; the projects wont even compile:

1>rtAudioD.lib(RtAudio.obj) : warning LNK4075: ignoring ‘/EDITANDCONTINUE’ due to ‘/OPT:ICF’ specification
1>fatal error C1007: unrecognized flag ‘-typedil’ in ‘p2’

And there was also problems with the osc library file in this version, it
was built using an older version, but this I managed to fix by swapping some files.

Then with nothing working I got desperate and installed
Visual Studio 2008 (MSDNAA version). I also downloaded
OF version 0.0573 which is compatible with VS2008. There,
I managed to get the most of the examples compiled,
but here too the programs won’t execute on another computer, getting a
similar error message by the source SideBySide:

Resolved Partial Assembly fail for Microsoft VC90.DebugCRT

And there’s a problem with osc as well. Trying to compile one of the
osc examples I get this message:

1>------ Build started: Project: oscSenderExample, Configuration: Debug Win32 ------
1>Linking…
1>fatal error C1900: Il mismatch between ‘P1’ version ‘20080116’ and ‘P2’ version ‘20070207’
1>LINK : fatal error LNK1257: code generation failed
1>Build log was saved at “file://c:\Libs\of_preRelease_v0.0573_windows_VS_FAT_v1\apps\addonsExamples\oscSenderExample\obj\Debug\BuildLog.htm”
1>oscSenderExample - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

and trying to build my project in 00573 I get the following:

1>ofTexture.cpp
1>…\libs\openFrameworks\app\ofAppRunner.h(10) : fatal error C1083: Cannot open include file: ‘ofAppEvents.h’: No such file or directory

And then finally trying to compile my 0.05 project with
version 0.06 of OF gives me this:

1>ControllerFaders.cpp
1>c:\libs\of_prerelease_v0.06_windows_vs2008_fat\libs\openframeworks\communication\ofstandardfirmata.h(38) : fatal error C1083: Cannot open include file: ‘ofEvents.h’: No such file or directory

So I guess to try OF 0.06 is a bad idea because it’s
not backwards compatible with 0.05…

How do I best solve this problem?
Is it a complicated process to convert my project to 0.06?
It’s a big project with about 110 files of code.

And if I do it, can I be sure that the project will run on another computer?

Or is there a solution using the 0.0573 version?

there was however no problem at all getting my project compiled
and running on the Mac platform.

Regards

Alfred

A little update here…

I actually managed to get things to work again. A lot of the problems was
solved by downloading SP1 for Visual Studio 2008 ( http://tinyurl.com/5lbw8p ).
To avoid confusion: I use the PRO version of Visual Studio, not the
Visual C++ 2008 Express Edition that is used in the setup guide.

I also managed to easily convert my old 0.05 project to 0.06
It was just a matter of removing and adding some addons-related
lines from the code. Everything working mostly fine with 006

Now the program works on my laptop as well. However, it
still won’t work on a third computer. There I still get the
“Resolved Partial Assembly fail for Microsoft VC90.DebugCRT” error.

This is because the dependent Visual C++ libraries cannot be found.

This problem seems to be related to how the project is set up in the property
setup of the VS project. There’s a reference to this problem on MSDN:
http://msdn.microsoft.com/en-us/library/ms235342.aspx

I also tried to convert my project to Code:blocks and compiled
it there, and that version ran perfectly on all computers, so the
problem must be related to Visual Studio or how the project is set up.

Has anybody else experienced this?

Al

I have the same problem.
The project compiles in Debug mode, but not in release mode. If I try to compile in Release I get a “fatal error LNK1257: code generation failed”.

When I try to launch the debug program in other computer I get a “the application has failed to start because its side-by-side configuration is incorrect” and a “Activation context generation failed for “G:\bin\blablabla.exe”. Dependent Assembly Microsoft.VC90.DebugCRT,processorArchitecture=“x86”,publicKeyToken=“1fc8b3b9a1e18e3b”,type=“win32”,version=“9.0.21022.8” could not be found. Please use sxstrace.exe for detailed diagnosis.” in the event log.

However, if I take my code to CodeBlocks I can compile it in Release mode and works perfectly in other computers. Note: I feel the rendering of the screen is a bit different in CodeBlocks and VS2008, is it possible?

I am using Visual Studio 2008 SP1, is there any chance to make it compiling in Release?
Thank you