Load videos from Raspberry Pi 3 B


#1

I have a video that I want my openFrameworks program to open and play from my Raspberry Pi, where should I put this video, in the bin folder? Also is it OK to use a .mov or should I convert it to something else? Currently getting a “ofGstVideoUtils: update(): ofGstVideoUtils not loaded” error but I think it’s for one of the reasons I’m asking about. I also tried creating a data folder inside the bin folder and putting the video in there but I am still getting the same error. Any suggestions?


#2

it needs to go in bin/data and should work with most formats including quicktime movs. Be sure to run the install_codecs.sh script after running install_dependencies.sh


#3

It’s still not working, getting the same error. Do I have to do install_dependencies right after install_codecs even though I have previously done install_dependencies (I did it recently, about 2-3 days ago when I was setting up my Raspberry Pi 3 B for the first time)? Or may there be another problem?


#4

no, no need to. in general most formats should work but it might be that the pi doesn’t support prores or some other propietary formats. try to check which codec the video is compressed with. usually h264 is the best supported in the pi


#5

Hello,
Have you tried using ofxOMXPlayer ? It’s an addon that is generally used on RPi for playback.


#6

How do I check the codec of the video? And how do I make my video an h264?


#8

I tried using the ofOMXPlayer but I keep getting errors, I have been trying to simply compile one of the examples (example-basic) but I get an error saying that it cannot find cairo.h. Any suggestions?


#9

Hey,
Have you executed the ’ install_depends.sh’ script ?
sudo ./ install_depends.sh
also be sure to use the master branch for the latest version


#10

I tried this and it just gives me a “command not found” error. Also, what do you mean by use the master branch?


#11

I mean the ‘releases’ are not up to date totally on this link (don’t use).

The master branch has nothing to do with trees and slaves, at least not the real ones…
this leads you to the master branch:
https://github.com/jvcleave/ofxOMXPlayer
then you can “clone or download” the latest version (unzip rename and copy via ssh, or directly on the Rpi do:

cd /home/pi/openFrameworks/addons
git clone https://github.com/kr15h/ofxPiMapper.git

I think ‘command not found’ means you need to :

sudo chmod a+x install_depends.sh

(give everyone full access to the file) before executing.

are you using latest raspbian stretch ?


#12

Just realized I was not in /home/pi/openFrameworks/addons/ofxOMXPlayer when doing sudo ./install_depends.sh (and by the way there is no space after ./ so it should be sudo ./install_depends.sh and not sudo ./ install_depends.sh). Works perfectly now. Thank you so much!