Load Errors on RPi 2

Hello,

I’m working on porting an oF app that I developed on rpi B+ to the new RPi 2. I’ve found a strange bug that I cannot seem to work around easily. When I try to load images or text from a URL I get a runtime segmentation fault during the ofLoadURL() call.

At first this bug only occurred when I used ofImage’s load() method or ofxJson’s .open method, but I could work around it by calling ofLoadURL() in the update loop directly and then calling ofLoadImage() of json.parse() on the loaded data. This worked alright for a few calls but then it crashed with a seg fault again and now it crashes every time. It’s worth noting that sometimes I get a bus error when it’s loading images specifically.

I’m unsure why this is happening, or how to fix it, or why the problem went away for a bit and then returned. so you can see I’m a bit stuck!

If anyone has any advise or needs more info let me know!

Thanks,

James Bentley

some more info and temp fix here

Cheers Jason! You’re ofLogVerbose() << “weird fix here”; trick totally worked!

Thanks a million!

1 Like