Load error on executable

Hi, everyone.
So I’ve been working on a project here which uses ofDirectShowPlayer and noticed that when I run the software from visual studio it loads the file but don’t play it, while if I run the release executable it doesn’t even load the file. I’m wondering why the executable doesn’t even load the file.

This also happens when I try to use ofxMultiSpeakerSoundPlayer, which works fine when running in visual studio but doesn’t load the audio files in the release executable.

Here is what happens when I run it using visual studio

And when I run the release executable

Hi,

Did you try installing the codecs linked at this step here:
https://openframeworks.cc/setup/vs/

The error message implies it is an issue with missing codecs.

Hope that helps!
Theo

Ok so I also some discrepancies with the k-lite recommendation, it says here to download the version 12.1.0
https://openframeworks.cc/learning/03_video/how_to_load_and_play_a_video/

But in your link it only redirects to the k-lite front page, which would make people download the most recent version.

I had to switch between both versions back and forth until I figured out that actually the problem was with the filename in the .xml I was using. So the message there was a little misleading as well in that regard. Then I fixed the filename and everything works fine now.

But anyway thanks for your help!

1 Like