LLVM GCC 4.2 Error; Permission denied to "include" directory

Hi Everyone,

i’m on OSX Lion 10.7.3.

i no longer can build or run any OF applications. i receive an error in my “Carbon.h” file. it seems like this file needs to reference other files in my “/usr/local/include/” directory. but my permissions to that directory is denied, so “Carbon.h” throws the error “LLVM GCC 4.2 Error”, then lists all the files that i cannot access due to my permission being denied.

to try to fix this, i ran disk utility to repair permissions but that changed nothing. i tried to change permission in terminal using “chmod” but no results their as well. i then re-installed xcode but still no results. does anyone have an idea about what may be happening ? i’m new to OF and c++ so i’m hitting a wall.

thank you

I just got this as well, none of my projects which were working fine last week seem to work. Eager to hear any news about this.

I’m assuming this is something to do with 10.7.3?

Can you post a screenshot of the Xcode window with the error?

What version of Xcode?

i thought it was a xcode 4.3 issue so i uninstalled and installed 4.2. but i unfortunately still got the error. i attached a screen shot.

thanks jvcleave

I get the same problem (Permission denied on all the #includes in Carbon.h).

Even just trying to compile EmptyExample from an unmodified instance of the openframeworks library (ie just extracted from the archive on the OF site with nothing else done to it) results in these errors for me.

edit: attached screencap

![](http://forum.openframeworks.cc/uploads/default/2228/Screen Shot 2012-02-28 at 16.55.21.png)

It is weird to me that it is looking for the classes in usr/local/include. In emptyExample.xcodeproj can you change your Base SDK to 10.6 and try it again?

Hmm things do seem to compile when I switch the base sdk to 10.6! I can only assume that this is something to do with the 10.7.3 update? Thanks for your help jvcleave :slight_smile:

thanks jvcleave that worked for me as well.

base sdk downgrade worked for me as well. thanks (where getting kindof mad :slight_smile:

Hello, I had the same problem 3 weeks ago but solved it by installing the Command Line Tools in XCode.
This is done via the Preferences. Go to Preferences->Downloads->Components and select Command Line Tools, then click on “Check and Install Now”.

I hope this helps,

Iannis Zannos