Linux (Ubuntu 13.04) and autocomplete in Code::Blocks

I am just getting started in openFrameworks on Ubuntu 13.04 (x64). It appears to install fine using the Code::Blocks instructions from the download page in that the example projects compile and run. The problem is that none of the oF code is available for autocomplete. I googled a bit and someone suggested trying a newer version of oF, so I grabbed the nightly build, but I’m running into the same issue.

Anyone have a clue as to what went wrong? Thanks!

are you opening the workspace or the cbp file? if you open the cbp you won’t get the openframeworks code in the workspace and it won’t be able to autocomplete

I should have specified - yes I am opening the workspace file, but the autocomplete still doesn’t show up for oF code.

Yes I noticed this earlier, should have filed a bug report but wasn’t sure if it was just my system.

So a couple of things. Firstly, the version of Codeblocks that OF pulls in from the repositories in Ubuntu 13.04 has a couple of broken plugins that crash on startup. I found that adding the following ppa and updating fixed this:

  
sudo add-apt-repository ppa:pasgui/ppa  
sudo apt-get update  

Also, to get autocomplete working again, go to Settings->Editor->Code Completion->C/C++ Parser and select “Use one parser for the whole workspace”

I have a feeling this is due to the newer version of CB having new default settings.

1 Like

Also, to get autocomplete working again, go to Settings->Editor->Code Completion->C/C++ Parser and select “Use one parser for the whole workspace”

Ahhh, such a simple solution - thank you!

I found that adding the following ppa and updating fixed this

Hmm, I had done this, but I had also tried uninstalling the C::B that comes with OF and re-installing with the one that the software center pulls down. I don’t remember which I did first, but one of them fixed the broken plugins. Now I’m guessing it was probably the ppa then.

I have the same issue on ubuntu 13.10, but the suggested workaround doesn’t work.
Any other idea?

Ok, I’ve found out this bug report:

The workaround suggested there did work for me.