Linker command failed with exit code 1 (use -v to see invocation)

Hi!
I’m trying to compile my first program in open framework.
I followed this guide
http://openframeworks.cc/learning/01_basics/how_to_create_slider/

Every time I try to run the program Xcode give me this error :

linker command failed with exit code 1 (use -v to see invocation)

I tried to locate ofApp.o and main.o, but they not seem to be duplicated. I tried to delete them too but I can’t.

OSX 10.11.3 (15D21)
Open Frameworks 0.9.3
Xcode 7.2.1 (7C1002)

Hope someone can help me :slight_smile:
Stefano.

it looks like you put radius in your main.cpp file? Make sure it is only declared in ofApp.h

Hi jvcleave, thank you for the response.
Nope I’m sure I declared it only ofApp.h


you need to put the two variables (radius and gui) inside the ofApp class. (ie, move those two lines to below “gotMessage”)
since these variables are part of the ofApp object and will be used in functions like setup and draw.

Also, you can take a look at some of the other examples that ship with OF if you need to see what I mean.

Ops! I clearly misunderstood the guide, thank you very much!

Now Xcode build the program, but the slider is not visible on the screen, it can be connected with this warning?

This is the code :