Libusbemu problem + ofxKinect


#1

Hi all,

I’ve been using two different Kinects to play around and got to write a modified version of a particle system that I was pretty satisfied with.
I got myself a new Kinect (1473, ouch) and I’ve started running into problems. But I have no idea where to start looking.
In Failed Build I get these errors:

libusbemu_theads.h
User Defined Issues
LIBUSBEMU PTHREAD WRAPPER NOT YET IMPLEMENTED

I have also changed from gcc 4.0 to 4.2, but I’m not sure if that may have something to do with all this. I’m sorry I can’t be more specific about my issue.

Thanks for your help!

Franc


#2

Ok, so the problem has nothing to do with the model of the Kinect (as I should have imagined)

I’m trying now with a 1414 and it doesn’t give me any trouble in Processing using SimpleOpenNI, but I’m still running into the same problem.

I tried reinstalling openFrameworks 0062, adding ofxKinect and checking out 0062 (as it says in the ofxK guidlines) but still no luck. I’m back now to 074. I created a project out of the kinectExample, adding ofxOpenCV and ofxKinect.

This is the list of errors I’m getting. I’m on Mountain Lion 10.8.4. It’s weird because all these errors seem to belong to files for windows. I should say I’m clearly new to most of this, so bear with me please :stuck_out_tongue:

  
clang: warning: -lpthread: 'linker' input unused  
In file included from /Users/franc/Documents/openFrameworks/addons/ofxKinect/kinectExample/../../../addons/ofxKinect/libs/libfreenect/platform/windows/libusb10emu/libusb-1.0/libusbemu.cpp:68:  
In file included from ../../../addons/ofxKinect/libs/libfreenect/platform/windows/libusb10emu/libusb-1.0/libusbemu_internal.h:30:  
../../../addons/ofxKinect/libs/libfreenect/platform/windows/libusb10emu/libusb-1.0/libusbemu_threads.h:45:4: error: LIBUSBEMU PTHREAD WRAPPER NOT YET IMPLEMENTED!  
  #error LIBUSBEMU PTHREAD WRAPPER NOT YET IMPLEMENTED!  
   ^  
../../../addons/ofxKinect/libs/libfreenect/platform/windows/libusb10emu/libusb-1.0/libusbemu_threads.h:54:3: error: unknown type name 'QuickMutex'  
  QuickMutex& m_mutex;  
  ^  
../../../addons/ofxKinect/libs/libfreenect/platform/windows/libusb10emu/libusb-1.0/libusbemu_threads.h:55:13: error: unknown type name 'QuickMutex'  
  RAIIMutex(QuickMutex& mutex) : m_mutex(mutex) { m_mutex.Enter(); }  
            ^  
In file included from /Users/franc/Documents/openFrameworks/addons/ofxKinect/kinectExample/../../../addons/ofxKinect/libs/libfreenect/platform/windows/libusb10emu/libusb-1.0/libusbemu.cpp:68:  
In file included from ../../../addons/ofxKinect/libs/libfreenect/platform/windows/libusb10emu/libusb-1.0/libusbemu_internal.h:31:  
/Users/franc/Documents/openFrameworks/addons/ofxKinect/kinectExample/../../../addons/ofxKinect/libs/libusb-win32/include/lusb0_usb.h:5:10: fatal error: 'windows.h' file not found  


#3

As you guessed, it looks like you’re loading the wrong version of libfreenect. The Windows version, which uses libusbemu, not the Linux/Unix version, which doesn’t. I’m not too familiar with ofxKinect but you should carefully check how you have your project set up, make sure you’ve grabbed the right version of the library or that you’re linking to the right stuff?


#4

franc! i just had the same exact issue right now, and i’ve been trying to fix it for 2 hours and you are the ONLY person on the internet with this error! :’)

it took me so long to figure this out… the solution was to set:
“other linker flags” in build settings to

../../../addons/ofxKinect/libs/libusb-1.0/lib/osx/usb-1.0.a

(posting it for people in the future coming across the same problem)

– sarah (from sfpc!)


#5

hi Sarah, I know you posted 2 years ago :slight_smile: but just in case you remember, where exactly is “other linker flags” in build settings? thanks!


#6

hi louisa, i attached a screenshot, it’s under “Linking” (i use Xcode)

hope this helps!


#7

oh thank you!!! I use visual studio so will try to find equivalent :slight_smile: