Ld.exe: cannot find -lz , ld.exe: cannot find -lstrmbase

Hey guys
fiirst of all, I’m supernew to the forum,code blocks and open frameworks -> this is my firs post :slight_smile:

I’m trying to run the examples from of_v0.7.4_win_cb_release on Code::Blocks 12.11
I started by setting up the codeblocks addistions as http://www.openframeworks.cc/setup/codeblocks/ shows.
Then I open a random example in codeblocks, in this case is normalsExample.workspace
When I hit on run, code blocks starts compiling the code untill I get the following errors:

ld.exe: cannot find -lstrmbase
ld.exe: cannot find -lz

I have no clue what could be wrong.

Here is the entire build log

-------------- Build: release in openFrameworksLib (compiler: GNU GCC Compiler)---------------

Target is up to date.

-------------- Build: release in normalsExample (compiler: GNU GCC Compiler)---------------

mingw32-g++.exe -o bin\normalsExample.exe obj\release\src\main.o obj\release\src\testApp.o -s …/…/…/libs/openFrameworksCompiled/lib/win_cb/openFrameworks.lib …\libs\FreeImage\lib\win_cb\FreeImage.lib …\libs\rtAudio\lib\win_cb\librtaudio.a …\libs\quicktime\lib\win_cb\qtmlClient.lib …\libs\cairo\lib\win_cb\libcairo.a …\libs\cairo\lib\win_cb\libpixman-1.a …\libs\freetype\lib\win_cb\libfreetype.a …\libs\glut\lib\win_cb\libglut.a …\libs\videoInput\lib\win_cb\videoInputLib.a …\libs\fmodex\lib\win_cb\libfmodex.a …\libs\glew\lib\win_cb\glew32s.lib …\libs\glu\lib\win_cb\glu32.lib …\libs\poco\lib\win_cb\libPocoNet.a …\libs\poco\lib\win_cb\libPocoUtil.a …\libs\poco\lib\win_cb\libPocoXML.a …\libs\poco\lib\win_cb\libPocoFoundation.a …\libs\tess2\lib\win_cb\libtess2.a -lopengl32 -lgdi32 -lmsimg32 -lglu32 -ldsound -lwinmm -ldxguid -lstrmbase -lstrmiids -lz -luuid -lole32 -loleaut32 -lsetupapi -lwsock32 -lws2_32 -lIphlpapi -lComdlg32
c:/program files (x86)/codeblocks/mingw/bin/…/lib/gcc/mingw32/4.7.1/…/…/…/…/mingw32/bin/ld.exe: cannot find -lstrmbase
c:/program files (x86)/codeblocks/mingw/bin/…/lib/gcc/mingw32/4.7.1/…/…/…/…/mingw32/bin/ld.exe: cannot find -lz
collect2.exe: error: ld returned 1 exit status
Process terminated with status 1 (0 minutes, 1 seconds)
2 errors, 0 warnings (0 minutes, 1 seconds)

Thank you very much for your help!!

please read this page http://openframeworks.cc/setup/codeblocks/
they tell us add some file into codeblocks folder,