latest OF and ubuntu 10.4.1

using the latest OF off github and ubuntu 10.4.1 x64, code::blocks installed successfully but then the dependencies caused this error:

  
  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid Release.gpg  
Ign [http://qa.archive.ubuntu.com/ubuntu/](http://qa.archive.ubuntu.com/ubuntu/) lucid/main Translation-en_US  
Ign [http://qa.archive.ubuntu.com/ubuntu/](http://qa.archive.ubuntu.com/ubuntu/) lucid/restricted Translation-en_US  
Ign [http://qa.archive.ubuntu.com/ubuntu/](http://qa.archive.ubuntu.com/ubuntu/) lucid/universe Translation-en_US  
Ign [http://qa.archive.ubuntu.com/ubuntu/](http://qa.archive.ubuntu.com/ubuntu/) lucid/multiverse Translation-en_US  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid Release  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid/main Packages  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid/restricted Packages  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid/main Sources  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid/restricted Sources  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid/universe Packages  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid/universe Sources  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid/multiverse Packages  
Hit [http://qa.archive.ubuntu.com](http://qa.archive.ubuntu.com) lucid/multiverse Sources  
Reading package lists... Done  
Reading package lists... Done  
Building dependency tree         
Reading state information... Done  
Some packages could not be installed. This may mean that you have  
requested an impossible situation or if you are using the unstable  
distribution that some required packages have not yet been created  
or been moved out of Incoming.  
The following information may help to resolve the situation:  
  
The following packages have unmet dependencies:  
  libgl1-mesa-dev: Depends: libgl1-mesa-glx (= 7.7.1-1ubuntu2) but 7.7.1-1ubuntu3 is to be installed  
  libglu1-mesa-dev: Depends: libglu1-mesa (= 7.7.1-1ubuntu2) but 7.7.1-1ubuntu3 is to be installed  
  libgstreamer-plugins-base0.10-dev: Depends: libglib2.0-dev but it is not going to be installed  
  libgstreamer0.10-dev: Depends: libglib2.0-dev but it is not going to be installed  
E: Broken packages  
compiling object for  ../../../openFrameworks/communication/ofSerial.cpp  
mkdir -p obj/Debug/openFrameworks/communication  
g++ -g3 -Wall -fexceptions -I../../../FreeImage/include -I../../../fmodex/include -I../../../freetype/include -I../../../freetype/include/freetype2 -I../../../freetype/include/freetype2/freetype -I../../../freetype/include/freetype2/freetype/config -I../../../glee/include -I../../../glu/include -I../../../glut/include -I../../../gstappsink/include -I../../../gstappsink/include/gst -I../../../gstappsink/include/gst/app -I../../../poco/include -I../../../poco/include/Poco -I../../../poco/include/Poco/Net -I../../../poco/include/Poco/XML -I../../../poco/include/Poco/DOM -I../../../poco/include/Poco/Util -I../../../poco/include/Poco/SAX -I../../../poco/include/Poco/Dynamic -I../../../poco/include/CppUnit -I../../../quicktime/include -I../../../rtAudio/include -I../../../videoInput/include -I../../../openFrameworks/ -I../../../openFrameworks/communication -I../../../openFrameworks/sound -I../../../openFrameworks/events -I../../../openFrameworks/app -I../../../openFrameworks/video -I../../../openFrameworks/utils -I../../../openFrameworks/graphics `pkg-config  gstreamer-0.10 gstreamer-video-0.10 gstreamer-base-0.10 libudev libavcodec libavformat libavutil --cflags`  -MMD -MP -MFobj/Debug/openFrameworks/communication/ofSerial.d -MTobj/Debug/openFrameworks/communication/ofSerial.d -o obj/Debug/openFrameworks/communication/ofSerial.o -c ../../../openFrameworks/communication/ofSerial.cpp  
Package gstreamer-0.10 was not found in the pkg-config search path.  
Perhaps you should add the directory containing `gstreamer-0.10.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'gstreamer-0.10' found  
Package gstreamer-video-0.10 was not found in the pkg-config search path.  
Perhaps you should add the directory containing `gstreamer-video-0.10.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'gstreamer-video-0.10' found  
Package gstreamer-base-0.10 was not found in the pkg-config search path.  
Perhaps you should add the directory containing `gstreamer-base-0.10.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'gstreamer-base-0.10' found  
Package libudev was not found in the pkg-config search path.  
Perhaps you should add the directory containing `libudev.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'libudev' found  
Package libavcodec was not found in the pkg-config search path.  
Perhaps you should add the directory containing `libavcodec.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'libavcodec' found  
Package libavformat was not found in the pkg-config search path.  
Perhaps you should add the directory containing `libavformat.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'libavformat' found  
Package libavutil was not found in the pkg-config search path.  
Perhaps you should add the directory containing `libavutil.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'libavutil' found  
/bin/sh: g++: not found  
make: *** [obj/Debug/openFrameworks/communication/ofSerial.o] Error 127  
there has been a problem compiling Debug OF library  
please report this problem in the forums  
  

i tried upgrading and downgrading various packages until everything compiled. i eventually got it compiling, but code::blocks wouldn’t start. now when i try to restart it gives me the login screen (it shouldn’t, i auto-login) and when i try to login it goes black and kicks me back to the restart screen.

fortunately i wasn’t experimenting on my own computer… :slight_smile: i’m going to try installing 10.10 again and hope that various nvidia/xorg conflicts i was running into last month have been solved by now.

i had some similar issues after installing 10.10, but they went away once i went through the update manager’s updates. i had been avoiding running the update manager because it was causing my apt to break in 10.4, complaining about the ubuntu headers, and they put things in a state where it was impossible to install openssh-server.

i was going to just compile on the 10.10 machine and distribute the app to 10.4 machines but it looks like there are some dynamically linked libraries that aren’t up to date… and when i try to install them it complains about dependencies until it’s back to the 7.7.1-1ubuntu2 vs 7.7.1-1ubuntu3 thing again.

aughhhhh linuuux…

sry, can’t help there, never had such problems on 10.10. but i’d guess if you update manager breaks your apt (!?), then there’s something wrong which has nothing to do with oF.
What does that mean anyway “break apt”? update-manager is just a gnome apt front-end, afaik.

‘breaks apt’ was a bad was to put it. what i meant was: when i run the update manager (which pops up by default after installing) and install updates to all the preinstalled packages, it puts my system in a state where i can’t install openssh-server – whether i’m using synaptic or manually poking around apt-get.

i upgraded everything to 10.10 and the latest nvidia and xorg packages from the ppa, and things seem to be ok. left it running over night, we’ll see if the same errors come back as last time i tried this…

there is still an unresolved issue, but i’m not worried about it atm: if you install 10.4.1 and don’t install the updates, OF throws the errors below when trying to install the packages it needs from the dependencies script. just something to keep in mind if you ever want to run OF off an ubuntu machine without an internet connection: don’t use 10.4.1