Latest emscripten doesnt work on examples

hey @stephanschulz,
I am having the same problem.
I tried setting the http-server too, but it fails in the same way.
I am in High Sierra and OF GitHub branch.

I didn’t know how to setup this (from OF website):
(Maybe this can be the problem…)So I need to run source ./ every time…

type source ./ to set the system path to the active version of Emscripten. You can copy the output of this command and add it to your .profile file, in order to save this variables also for the next sessions.

  1. I open a terminal:
    cd /Users/myUser/Documents/emsdk
  2. then I run:
    source ./
  3. run:
    cd /Users/myUser/Documents/openFrameworks/examples/gui
  4. create project with PG with emscripten template.
  5. run:
    emmake make emrun --browser chrome bin/guiExample.html

I used the same @alp guide.

These steps worked for me on macOS 10.14
It took forever to build emsdk but once it was done.

I could build examples with:
emmake make
emrun --browser chrome bin/3DPrimitivesExample.html

Worked beautifully.
I’ll update the setup guide accordingly ( the git url now points to )

Note: Might be good to remove old installs of emsdk and any .emscripten files in your home folder before installing/building emsdk as above.

Thanks @theo,
but I followed your steps here in 10.13 but do not worked. Getting this final error when compiling an example:

error: undefined symbol: _ZN5boost10filesystem4path25m_path_iterator_incrementERNS1_8iteratorE
warning: To disable errors for undefined symbols use `-s ERROR_ON_UNDEFINED_SYMBOLS=0`
error: undefined symbol: _ZN5boost10filesystem4pathdVEPKc
error: undefined symbol: _ZN5boost10filesystem4pathdVERKS1_
error: undefined symbol: _ZN5boost10filesystem6detail12current_pathEPNS_6system10error_codeE
error: undefined symbol: _ZN5boost10filesystem6detail16create_directoryERKNS0_4pathEPNS_6system10error_codeE
error: undefined symbol: _ZN5boost10filesystem6detail18create_directoriesERKNS0_4pathEPNS_6system10error_codeE
error: undefined symbol: 

error: undefined symbol: _ZN5boost10filesystem6detail9canonicalERKNS0_4pathES4_PNS_6system10error_codeE
error: undefined symbol: _ZN5boost10filesystem8absoluteERKNS0_4pathES3_
error: undefined symbol: _ZN5boost6system15system_categoryEv
error: undefined symbol: _ZN5boost6system16generic_categoryEv
error: undefined symbol: _ZNK5boost10filesystem4path11parent_pathEv
error: undefined symbol: _ZNK5boost10filesystem4path14root_directoryEv
error: undefined symbol: _ZNK5boost10filesystem4path3endEv
error: undefined symbol: _ZNK5boost10filesystem4path5beginEv
error: undefined symbol: _ZNK5boost10filesystem4path7compareERKS1_
error: undefined symbol: _ZNK5boost10filesystem4path9extensionEv
Error: Aborting compilation due to previous errors
shared:ERROR: '/Users/myUser/emsdk/node/12.9.1_64bit/bin/node /Users/myUser/emsdk/emscripten/incoming/src/compiler.js /var/folders/v9/y47_kxhs2xlfxtywq5mzj3x40000gn/T/tmpqdyxpS.txt' failed (1)
make[1]: *** [bin/guiFromParametersExample.html] Error 1
make: *** [Release] Error 2

ok. sorry @theo . it worked!
I forget to run the script for libs again:


so, @stephanschulz, you can try this way.
it’s working here fine. The local http server setup was not required when you run the app with
emrun --browser chrome bin/advanced3dExample.html
because it seems ‘it runs his own server’

I noticed that when running the emscripten/, macOS building stops working, so we can’t share the OF folder to both buildings.


  1. how can we add the profile to the system to avoid running source ‘./’ every session?
  2. there’s any way to made it run in Safari? What are the main limitations of Emscripten vs native app?

done that.

then followed the same steps as @Jona

git clone
cd emsdk
./emsdk install sdk-incoming-64bit binaryen-master-64bit
./emsdk activate sdk-incoming-64bit binaryen-master-64bit
source ./

Then use PG to create guiExample with Emscripten template:

then cd to:

emmake make

and get this error:
shared:ERROR: fastcomp is not compatible with wasm object files:obj/emscripten/Release/src/ofApp.o
make[1]: *** [bin/guiExample.html] Error 1
make: *** [Release] Error 2

FYI my nightly build of_v20191201_osx_release does not have

this is /openFrameworks/scripts/emscripten (260 Bytes)

this is /openFrameworks/dev folder, maybe there’s more files required, sorry… (23.0 KB)

I think this assumes the GitHub version of OF. not the nightly build? since I do not have a ./dev/

I am using GitHub version… Refresh this post, I added /dev too… just in case it makes it simpler…

Regarding your second question: ofxMidi, ofxOsc, ofSystemLoadDialog and some of the input_output examples do not work with Emscripten… but there are some workarounds: exchanging integers / floats between open frameworks and java script is quite easy, but replacing something like ofSystemLoadDialog seems a bit complicated, at least for me. Another limitation is that you need to use GL ES instead of GL SL if you want to use shaders.
Thats what I found so far…

You can list and choose the browser with:

emrun --list_browsers
emrun --browser safari

1 Like

I placed your dev folder in the scripts folder.
now running from the emscripten did start installing a bunch of stuff.

just to be sure I ran again:
./emsdk activate sdk-incoming-64bit binaryen-master-64bit
source ./

still, emmake make produces same error.

I guess I will download the GitHub OF version and try it with that.

thanks again for your help

eureka. it works.

I downloaded the latest nightly build:

opened a new terminal window.
since I already followed the earlier install steps I just had to redo the last two steps.
cd emsdk
./emsdk activate sdk-incoming-64bit binaryen-master-64bit
source ./

then in the same terminal window cd to the project folder.
then call emmake make
and the build worked :slight_smile:

I did not need to install via /openFrameworks/scripts/emscripten/

thanks everyone

1 Like

I was just going to write I think the issue is that you should delete the contents of:
⁨libs⁩ ▸ ⁨openFrameworksCompiled⁩ ▸ ⁨lib⁩ ▸ ⁨emscripten⁩

When switching to different emsdk versions.
I think the reason the nightly worked is that it hadn’t compiled the OF project with a different emsdk.
( I ran into this yesterday )

I would guess if you downloaded a fresh zip of 0.11.0 to a different location and do the steps in your last post it would also work.

Thanks everyone for helping with this though.
Its fairly gnarly to debug.

And if anyone is feeling brave and wants to help figure out why this is happening - would be amazing:


/dev folder goes outside /scripts…

thanks for this info.

the two examples worked fine.
but trying to compile my own project still produces errors.

warning: To disable errors for undefined symbols use -s ERROR_ON_UNDEFINED_SYMBOLS=0

Error: Aborting compilation due to previous errors

shared:ERROR: ‘/Users/stephanschulz/emsdk/node/12.9.1_64bit/bin/node /Users/stephanschulz/emsdk/emscripten/incoming/src/compiler.js /var/folders/q0/p6sww9k10816nqt8ldgg03c40000gp/T/tmpZzOWVM.txt’ failed (1)

make[1]: *** [bin/guiFromParametersExample.html] Error 1

make: *** [Release] Error 2

I tried to delete the Emscripten folder content as you suggested.
also started new terminal window and ran ./emsdk commands as mentioned earlier.

also noticed when making edits to the guiExample src and calling emmake, I did not see those code changes take effect.

@stephanschulz Did you also delete the emscripten folder of the guiExample? Normally the changes should take effect if it runs at all. Regarding your own example: Is it possible that you use some addons or functions that are not compatible with Emscripten? There seems something wrong with a .txt file…

@Jona thanks for pointing this out. I only now notice that running emmake creates a folder called obj with an Emscripten folder inside.

@Theo as mentioned earlier I am now able to compile and run guiExample. BUT as soon as I add gui.loadFromFile(“settings.xml”); to setup() the app will not run successfully in the browser. I guess Emscripten apps do not like loading and writing to disk?

@stephanschulz I think you can not read files from disk easily/the used way with Emscripten.
But you can read files that are in the Data folder of the Emscripten project.
This could be a start for reading files from disk, I do not understand it by myself:
and here @kokawa2003 managed to save an image to disk with Emscripten: I want to save image

settings.xml is in my data folder.
and usually calling

retrieves this xml file from the data folder. but maybe with Emscripten I need to change the file path?

@stephanschulz Then it is something else. I do not think that you need to change the file path.

files in data are packed in a special format and served as a file system emulation when you use emmake make run so it should work. if you compile the aplication in debug you should get a proper stack trace when the app crashes which will give you a clue of what might be going on.