lasound error

hi everybody!

recently i installec linux (ubuntu 8.10) in my computer and i’m trying to install codeblocks on it.

I believe i haven’t miss any step on the installation …

So… the problem is: everytime i try to compile one of the OF examples it gives an error

cannot find - lasound

I can’t figure out what i did wrong during the installation process and just wondering if someone had the same problem and knows how to fix it.

Thanks everybody and take care

Hey charly

surely you’ve missed this step in the setup guide for codeblock linux:

in addition to those commands, do these at the command line

sudo apt-get install freeglut3 freeglut3-dev
sudo apt-get install alsa-dev
sudo apt-get install libxmu-dev libxxf86vm-dev

anyway, under ubuntu you can execute the install_codeblcks.sh script in the scripts folder to automatically download and install codeblocks and all the dependencies. It doesn’t matter if you already installed something, it should work anyway.

You’ll need to give execution permissions to the script, then execute from a terminal:

  
cd OF_DIRECTORY/scripts  
sudo ./install_codeblocks.sh   

hi arturo!

Thank you so much… but i think the problem is something else.

i followed you’re advice and … :frowning:

when i try to install

" sudo apt-get install alsa-dev" tells me that it can find it. i also tryed using synaptics and no use.

and this

  
  
  
Code:<div class="inside_code">cd OF_DIRECTORY/scripts  
<br>sudo ./install_codeblocks.sh </div>  
  
  

says that it can’t find it…

take care

sorry the name of alsa-dev changed some time ago, now you should do:

  
ssudo apt-get install libasound-dev  

also when I wrote:

cd OF_DIRECTORY/scripts

you should substitute OF_DIRECTORY with the directory where you have openframeworks.