Kinect on Fedora 16

Hey guys.

I’m VERY new to linux and my first project is to get my kinect to run. What I did:
I cloned the git version of ofxKinect to my addon folder. I opened the workspace with codeblocks and tried to compile. Sadly enough this is not working. I got this error:

  
||=== ofxKinectExample, Debug ===|  
../../ofxOpenCv/src/ofxCvHaarFinder.cpp||In member function ‘void ofxCvHaarFinder::draw(float, float)’:|  
../../ofxOpenCv/src/ofxCvHaarFinder.cpp|141|warning: comparison between signed and unsigned integer expressions [-Wsign-compare]|  
../src/ofxKinect.cpp||In member function ‘virtual void ofxKinect::update()’:|  
../src/ofxKinect.cpp|225|warning: unused variable ‘n’ [-Wunused-variable]|  
../src/ofxKinect.cpp||In member function ‘void ofxKinect::updateDepthLookupTable()’:|  
../src/ofxKinect.cpp|496|warning: comparison between signed and unsigned integer expressions [-Wsign-compare]|  
../src/ofxKinect.cpp|519|warning: variable ‘curMode’ set but not used [-Wunused-but-set-variable]|  
../libs/libfreenect/cameras.c|749|warning: ‘read_register’ defined but not used [-Wunused-function]|  
/usr/bin/ld: ../../../libs/openFrameworksCompiled/lib/linux64/libopenFrameworksDebug.a(ofTexture.o)||undefined reference to symbol 'gluBuild2DMipmaps'|  
||note: 'gluBuild2DMipmaps' is defined in DSO /usr/lib64/libGLU.so.1 so try adding it to the linker command line|  
||=== Build finished: 1 errors, 5 warnings ===|  

So I change my makefile. I added libGLU.so.1 like this:
USER_LDFLAGS =/usr/lib64/libGLU.so.1

Now the program compiles, but I get no image whatsoever.
Can anybody help me?

BTW: Why won’t the program start from the IDE? Why do I always have to start it manually? What if I want to debug?

Now the program compiles, but I get no image whatsoever.

have you installed correctly the kinect drivers? libfreenect?

Strange that you have to add the linker flag … you can also do USER_LIBS = -lGLU

I found the solution. I have to start the program as root.
But still: Why?
And also: Can I debug in the IDE? (using breakpoints and stuff)

because You must add the USER to the video group:

sudo adduser $USER video

http://openkinect.org/wiki/Getting-Started
I usually use the codeblocks debugger ,don’t know why you have this issue…

I tried adding the user to the video group. But it still won’t run without being root.