Kinect not delivering data with 2015 MacBook Pro running Mojave 10.14.6

#1

I am having trouble getting Kinect for Windows v2 (I think it is v2 - is there a failsafe way to make sure?) to work on my 13" 2015 MacBook Pro running Mojave 10.14.6.

My system report does successfully recognize the “Microsoft Kinect Camera” and “Kinect for Windows USB Audio” as being plugged into the USB ports (I’ve tried both ports to no avail), but when I run the ofxKinect example that came with OpenFramework in XCode, I get a LIBUSB_ERROR_NOT_FOUND isochronous transfer error. I’m not sure if it’s a problem with the libusb library that is included with ofxKinect?

Then eventually it says “device -1 isn’t delivering data” and tries to reconnect.

#2

Hi,
you need to use ofxKinectV2. ofxKinect is for the kinectV1. Cheers

#3

Thanks so much for your help! I’m trying to run the OpenFramework 0.10.1 kinectExample project in XCode, and I’m wondering if it would work to just replace the ofxKinect addon that comes with it with the ofxKinectV2?

I’m a bit of a beginner to XCode, so having trouble figuring out all the things I need to change to make this work. I notice besides having different libfreenect2 and libusb libraries, ofxKinectV2 also comes with protonect. For now I just tried replacing the ofxKinect lib and src folders with the ofxKinectV2 ones, but even though I think I added all the right header search paths to the kinectExample project, it’s still complaining that it cannot find libfreenect2/double_buffer.h when I try to build.

I’m also a little unsure about the meaning of these two points from the ofxKinectV2 readme:

  • If you have the ofxKinect ( v1 ) addon in your project remove the ofxKinect libusb lib and use the one that comes with this repo instead.
  • On OS X if you are not using the example project. Make sure to add OpenCL.framework to the Link Binary With Library Build Phase and also change the line in Project.xcconfig to OTHER_LDFLAGS = $(OF_CORE_LIBS) $(OF_CORE_FRAMEWORKS) -framework OpenCL
#4

Hi,
dont use ofxKinect’s example. Use the one that comes with ofxKinectV2. You’ll probably need to update the xcode project for the example, which is really easy. Open Project Generator and just drag and drop over it ofxKinectV2’s example folder. Then press update in Project Generator. Once done just compile in xcode.
Just as a side note, dont try to add or remove addons from xcode manually, it is a lot easier to do such with the project generator.
After doing such the project builds with no problem.

cheers

#5

Thank you so much! The project builds now, but I think it’s still having trouble connecting to my Kinect. I have tried unplugging and replugging the power while the USB is still connected. I have also tried both USB ports on my laptop.

I am confused by the sentence “ofxKinectV2 will only work if the NUI Sensor shows up in the Superspeed category of the System Profiler in the USB section” - I don’t see any Superspeed category, or any speed categories at all. Below is what I see when I have the Kinect plugged in:

#6

It may also be relevant to note that if I turn on the verbose option for libfreenect2, the output reads as follows (I don’t know why it is detecting 3 devices, the Kinect is the only thing plugged in):

[Info] [Freenect2Impl] enumerating devices…
[Info] [Freenect2Impl] 3 usb devices connected
[Info] [Freenect2Impl] found 0 devices

I also tried plugging the Kinect into all of the ports on an iMac running Yosemite 10.10.5 and the ones that recognized it all said USB 3.0 Hi-Speed rather than Superspeed. I tried the tip about leaving the USB plugged in while replugging the power, to no avail.

#7

Superspeed or Hi Speed USB, probably apple changed how it names its USB 3.0 ports in the system info thing.
Is the kinect connected to the USB port directly (whitout any adaptor, hub or what ever else)? if not it is probably the problem. The kinectV2 is really picky about USB ports and it does not like some with certain chipsets (I can not recall which exactly)

#8

It’s connected directly, with no adaptors. I think the “hub” it’s referring to is the power hub that splits into the power cable and the USB cable. I even tried doing an SMC reset on my laptop just to make sure that wasn’t the reason it wasn’t properly detecting the USB device.

Also I thought that the USB had to be detected as Superspeed specifically and not Hi-speed for the ofxKinectV2 addon to work?

#9

mmm. No idea then. I’ve used it with no problems with ofxKinectV2 on a mid2014 15¨macbookpro with sierra and high sierra, but not with mojave.