Kinect example ubuntu 15.10 device isn't delivering data

libusb seems to be installed

I am in ubuntu 15 10

kinect works fine under osx

any ideas? :beer:

there’s some instructions in the readme of the addon on how to install it for linux. you have to add some config so the device is created with the correct permissions. the specific line is:

sudo cp libs/libfreenect/platform/linux/udev/51-kinect.rules /etc/udev/rules.d

but better read the readme to see how to use it

it didn’t work my man

have you tried restarting your computer? otherwise try using sudo

Here is what I’ve tried thus far:
sudo
dksu

…clicking “run as program” on the rules

(really can I force them any other way than putting them in the .d folder?)

tried sudo make clean then sudo make,

(the executable appeared with the locked sign meaning it is absolutely super user)

nothing …
tried removing solaar … an app I had for wireless keyboards…

nothing…

tried changing usb ports (all of them are usb 3) … nothing…

If I don’t solve this in a few days
I really have no other option than try the windows route.

…I am thinking installing windows Server 2016

The remote desktop of that finally allows real OPENGL support meaning you can run/ modify openframeworks apps by remote machines opening possibilities for many things…

I am using kinect for windows… if that matters?

I also tried to run the 51 script directly on therminal and got this…

I got a slightly different error when
I compiled with sudo make debug
and then executed with dksu

is this a breakthrough?

after commenting out the sound flag… I got a slightly different error for only one time…

[verbose] ofxKinect: 1 device found
[verbose] ofxKinect: id: 0 serial: 0000000000000000
[verbose] ofxKinect: open(): device 0 does not have motor control
[notice ] sensor-emitter dist: 7.5cm
[notice ] sensor-camera dist: 2.4cm
[notice ] zero plane pixel size: 0.1042mm
[notice ] zero plane dist: 120mm
[verbose] ofxKinect: device 0 0000000000000000 connection opened
[verbose] ofxKinect: device 0 connection closed
[warning] ofxKinect: update(): device 0 isn’t delivering data, reconnecting tries: 1
[verbose] ofxKinect: context inited

but then back to the above status… without even changing a line of code… :confused: so weird…

i just remembered that freenect didn’t work very well with usb3 on linux. i think it works for me in my latest computer but it never worked in the previous one which had a mixture of usb2 and 3 so that might be the reason

the machine I am using is a fairly expensive NUC i7
:confused: I miss my mac mini so bad.

same problem here on linux with xbox kinect 1473, works good on usb 2, these are some pointers i found to troubleshoot later, in case you want to jump in https://github.com/OpenKinect/libfreenect/issues/316 (i will when i have time)

1 Like