Issues with IOS openCV current git and nightly


#1

Is anyone else having troubles with openCV stuff on IOS? I am using OF from git and ran the download libs script. No examples with openCV will build (I get 200+ linker errors). I tried downloading a nightly to see if was my personal mess and I got the same errors. I am using a simulator (but that should be OK), I tried changing targets from iphones to ipads and still no joy. I am running 10.12.6 and Xcode 8.3.2

Errors start with :

: "_CFDataCreate", referenced from:
: "_CFStringGetCString", referenced from:
: "_SSLGetNegotiatedCipher", referenced from:

Examples and code without openCV seems to be OK for me.


#2

Bump…nobody, can anyone try this, just the openCV example with IOS?


#3

Hi @fresla

I just tried with Xcode 9.2 on 10.13 and Xcode 10 on 10.13

On Xcode 9.2 I get an error referencing 10.14 on Xcode 10 ( once I enable legacy build mode in the project settings ) it compiles for me without error for a generic device. If I run it in the simulator though I get a ton of errors. Is your issue with building for device or simulator?

If you are using the simulator does building for generic device work fine?

It could be that we aren’t compiling opencv for the simulator correctly or something with the addon is breaking the project.

Can you expand on the error does it show missing symbols for arch x86_64 ?

If that is the issue I can def duplicate and try and find a fix.


#4

I was trying with the simulator, I dont have an idevice at the moment but wanted to write the code before.

I wrecked my xcode by trying to add other SDKs, I will reset it and try again and give more details of the errors.

I did not know about the generic device, it is a good option to get around this, I know some things will not work with simulator anyway, I just wanted to make sure my code works (although not seeing it with the simulator sucks.

Is Xcode 8.3 too old for the current master branch of OF? Is there a minimum xocde and IOS SDK version?


#5

Ok, yes it is just with the simulator, I got hold of an iphone and I can run the openCV stuff, and the generic device does build as well.

Here are some of the errors with more details:

"_CVPixelBufferGetHeight", referenced from:
      ___39-[AVFoundationVideoPlayer loadWithURL:]_block_invoke_2 in libofxiOS_iphonesimulator_Debug.a(AVFoundationVideoPlayer.o)
      -[iOSVideoGrabber captureOutput:didOutputSampleBuffer:fromConnection:] in libofxiOS_iphonesimulator_Debug.a(AVFoundationVideoGrabber.o)
      ofxiOSVideoPlayer::getPixels() in libofxiOS_iphonesimulator_Debug.a(ofxiOSVideoPlayer.o)
  "_AVCaptureSessionPreset640x480", referenced from:
      -[iOSVideoGrabber initCapture:capWidth:capHeight:] in libofxiOS_iphonesimulator_Debug.a(AVFoundationVideoGrabber.o)
  "_AVAudioSessionInterruptionNotification", referenced from:
      -[SoundStream initWithNumOfChannels:withSampleRate:withBufferSize:] in libofxiOS_iphonesimulator_Debug.a(SoundStream.o)
      -[SoundStream dealloc] in libofxiOS_iphonesimulator_Debug.a(SoundStream.o)
  "_UIScreenDidDisconnectNotification", referenced from:
      -[ofxiOSAppDelegate applicationDidFinishLaunching:] in libofxiOS_iphonesimulator_Debug.a(ofxiOSAppDelegate.o)
  "_OBJC_CLASS_$_AVCaptureSession", referenced from:
      objc-class-ref in libofxiOS_iphonesimulator_Debug.a(AVFoundationVideoGrabber.o)