Issue with ofVideoGrabber in Ubuntu

Hi,

Sorry I’ve another basic question regarding ofVideoGrabber.

My system uses GStreamer 1.4.3 and the following kernel 3.16.0-36-generic (should be the latest available from ubuntu 14.10)

I run in the same issue as this post:

Since the latter was from October last year I thought I’d repost to see if there are any know bug / solution.

Basically I can see the video for 1 second but then it freezes and then on exit I have this error:

GStreamer-CRITICAL **: gst_mini_object_unref: assertion 'mini_object->refcount > 0' failed

I thought of downgrading the linux kernel but I’m not sure what version I should aim for.

Any help to debug this would be appreciated,

Xavier

this is a problem in how the v4l2 and appsink modules interact in newest gstreamer. i’ve reported it to the gstreamer bug tracker but haven’t been fixed yet. i’ve found a way to work around it and it’s fixed in the current version in master or in the nightly builds

Thanks @arturo, that worked perfectly.

Best,

Xavier