Issue installing Qt creator plugin

Hello,
Noob post.

After a good OF installation and Qt Creator 4.2.1 (ubuntu 16.04.2) I’m now trying to install the Qt plugin for OF but I get some bad news.

\
sudo ./install_template.sh
./install_template.sh: 7: ./install_template.sh: Bad substitution
\\

Any idea about what does it mean?

+1 having the same issue here. Ubuntu 16.04 / QT Creator 4.3

can compile the examples using make no issues, but the no dice in QT.
Also creating a new project doesnt actually include the addons from the wizard