iphone 3.2 simulator

am i missing something obvious, but when you are in the simulator, choose iphone device, then 3.2 as software, it resorts the ipad. its impossible to use the iphone in 3.2, only in 4.0

Here is a video
http://www.flickr.com/photos/pixelsumo/4927064534/

any ideas? thanks