iOS audioinput example in 0.9.8 doesn't receive any audio input


#1

Hi I am new to OF forum.

The audioinput example in the 0.9.8 ios release compiles and runs, and can play sound, but doesn’t receive any audio input.

I commented out codes related to the sound playing(output) , and now the audio input does work.

More specifically, this line seems to cause the no sound input issue:
sound.load(“sounds/beat.caf”);

I googled and found this old issue:

It is very similar to this so I guess issue #4551 is reawakened or may be not solved.

Also, I think this recent topic is the same issue:

…but I create as a new topic because maybe it’s not solved yet…

My environment is below:
iOS 11.3.1(iPhone5s)
openFrameworks 0.9.8

Thanks.


audioInputExample for iOS doesn't work on OF release 0.9.8
audioInputExample for iOS doesn't work on OF release 0.9.8
#2

can you check if this is still a problem with the nightly builds or the latest release candidate for 0.10?


#3

Hi thanks for the reply.

I just confirmed latest nightly build (of_v20180502_ios_release) has no problem above. Both input and output of the sound works correctly on the audio input example.

It seems that the sound playing function is switched from OpenAL to AVAudioPlayer. So I still need to check if sound play latency of AVAudioPlayer is feasible for my project… But I see the sound input problem in the example itself will be solved in a future release.

Thanks again and best regards,


#4

Hi,
For those who needs to use OF 0.9.8, a workaround is to play audio in an other thread (with ofThread).
I did that, and I can both record and play audio at the same time.

Cheers