Internal API Error

So I got openFrameworks working on my Jailbroken device. (Im using the serial port to receive data from a home made system).

I installed the program then using SSH moved it from
**private/var/mobile/applications **
to
private/var/stash/applications.pwn
it worked all fine and everything went well. So i then made some modifications to the file and to re-upload it i deleted the file from the stash folder so I could upload a fresh copy to mobile/applications and move it again.

However now when I load any OpenFrameworks app to the iPhone i get “Internal API error” however I can move any of my applications that don’t use OpenFrameworks.

Any ideas what the problem may be?

Thanks, Zaffro.

I can also confirm that it is nothing to do with any changes I have made to the package as I have re-downloaded a clean version and tried one of the examples and I still get the API error.

Thanks, Zaffro

EDIT:

Also if I manually upload using SSH the .app file from the /build folder into the /stash/applications folder the app uploads and the icon appears on the springboard but the application will not boot.

Thanks again, Zaffro