Interface Window + Output Window

Hello,

I have an application that plays fullscreen video, I also have interface elements built with the ofxControlPanel library.

Currently the interface and the output are sharing the same window, I would like to have a separate window for the controls but I have no idea how to go about it. I am sure that its a simple thing to do.

The only example I have found is this video, http://vimeo.com/16346790#comments but I can’t find a tutorial for implementing this. In this example the external interface is controlling Quartz patches and I am not sure if it works for a non quartz application.

Does anybody have any advice?

Hey sebben,

I’ve seen two ways of doing this.

there is an addon called ofxFenster which allows you to make another GLUT window to draw in
http://forum.openframeworks.cc/t/ofxfenster—addon-to-handle-a-second-window-[outdated]/3916/0

if you’re on a mac, you can use memo’s ofxCocoa, and create a window that spans all screens, then draw your video in one rectangle and your controls in another
http://forum.openframeworks.cc/t/new-ofxcocoa-was-ofxmacosx/4872/0

Hi Jim,
Thanks for your help again, I managed to get it working using ofxFenster method. Unfortunately I could not compile the ofxCocoa version.

After more head banging I now have less errors but instead I am getting.

#error gl.h included before glee.h

#error glext.h included before glee.h

Sheesh, coding is so hard for beginners with out documentation!

Try to “#include <gl.h>” in testApp.h before you include the ofxCocoa. This was the solution as far as i remember.

Thanks for the suggestion, but the same error persists.

Any other ideas?

hey Sebben,

sorry i missed your questions earlier and left ya hangin’!

The ofNotify errors are because memo’s ofxCocoa is built for the latest version of openFrameworks in the git repo:
https://github.com/openframeworks/openFrameworks

I had to work through all the same errors you saw when i was working on my temporary cities project -

I went ahead and put together a template project for doing these types of visual performances with ofxCocoa & openFrameworks. It creates a full screen canvas and based on the screen positions it will determine the area to draw the performer interface and the area to draw the public facing content screen.

it should be pretty flexible depending on one or two displays, and adapt to different display configurations. It’s not bullet proof, but as long as you have two displays that are sitting next to one another horizontally it should behave.

http://www.jamesgeorge.org/uploads/ofxC-…-mplate.zip

if you drop that project into the exampleApps folder of the latest pull from git it should fire right up. Sometimes you have to open up the the openFrameworks.xcodeproj project file, Get Info… on the top level project item and set the Architecture to 32-bit universal and set the Base SDK to 10.6.

If you hit any snags just let me know,

Hope this can help out!

Hello Jim,

Thank you for your help. However, I am still having issues compiling your example.

I have the latest OF, Xcode 3.2.2, SL 10.6.5 and I am compiling using GCC 4.0, 10.6 | Debug | i386

Here is the error message.

I am going to install the latest XCODE, and reinstall OF again and hopefully that will fix something.

S.

Hey Sebben,

I saw this too i think. I think the problem is on the openFrameworks library xcode project.

If you open the openFrameworksLib.xcodeproj under openFrameworks/libs/openFrameworksCompiled/project/osx, in xcode, get info on the project, and switch the native architecture to 32 bit and the SDK to either 10.5 or 10.6, then recompile it should take care of those errors.

Make sure the example project matches those settings too.


hope this fixes it. not sure why that happens, perhaps there is a more intentional fix.

Hi Jim,

I am now running 10.6.5, and XCODE 3.2.5 with the latest GIT OF and I have made the changes you suggested and now I end up with thousands of errors.

Which version of XCODE are you using?

The strange thing is I don’t even have the option to compile openFrameworksLib

hey sebben,

first make sure that the folder structure looks like this:
/openFrameworks/apps/examples/ofxCocoaTemplate/

not sure why you are getting all the missing files on the ofxCocoaTemplate project… but to get the openFrameworksLib compiled just hit COMMAND+B or select Build > Build. This library is also auto-compiled when you build any example app too, since all the example apps require the main openframeworks lib

Since the openFrameworksLib is a library and not an application, there is no build and go option - kind of confusing.

keep at it, it’s always a big stumbling block getting familiar with openFrameworks set up - but once you get it all built you’ll be fast on your way!

hope this helps,

Hi Jim.

I can’t even build the openframeworks library!

The files are in the folder structure you have suggested as well.

I think I may try and revert to my old version of XCODE.

I really have no idea why it isn’t working, I will keep chipping away with the old version of OF as well.

What version of XCODE are you using?

Cheers,
S.

Hey Sebben,

I’m using 3.2.5 as well - I don’t think this is an Xcode version problem. It seems like it’s a misconfigured build settings or missing files.

Lots of times when i am in Xcode trying to debug these issues I’ll end up messing other stuff up, and sometimes it’s better to just start with a clean ‘git clone’ from the latest repository. You should definitely be able to get the openFrameworksLib compiling, then after that tackle adding the template.

Sorry I can’t offer any more specific advice - i’ll keep noodling if I can come up with what it might be, but in the mean time just getting the latest oF building should be possible.

Forex-Trading-Robots
Personal-Finance-Planning
Instant-Approval-Payday-Loans

Well I got it down to only 72 errors by trying a new OF version.

I have changed my build settings to Compiler GCC 4.0 Architecture 32bit Universal but I still can’t build the OF library

I also tried these suggestions to no avail.
http://forum.openframeworks.cc/t/[solved]-xcode-compilation-problems-roundup-and-solutions/5052/0

hey sebben,

i see those are legit errors actually, the current git hub repository is pretty unstable because of the development conference going on right now.

Best to hang tight until it settles down and the 007 version is pushed out, at which point all the version woes should be done with =)

best,

Great thanks for the advice Jim.

I have managed to get the latest version off the GIT to compile now, but of course your example doesn’t compile now.

The error is that the glee library isn’t included in the present version from GIT and if I add the old version it spits out thousands of errors. Let me know if you manage to get it to compile with the latest OF version.

S.