install problem error "No Target! You should use wx-config progra

Hi, there, I was a beginner to linux and of.

When I was following the of instructions to install the of, using the ./install_codeblocks_svn.sh. I got the errors below.

/usr/include/wx/defs.h:42:13: error: #error “No Target! You should use wx-config program for compilation flags!”
In file included from wxsmith.cpp:23:0:
wxsmith.h:29:22: fatal error: cbplugin.h: No such file or directory
compilation terminated.
make[4]: *** [wxsmith] Error 1
make[4]: Leaving directory /root/rpm/codeblocks/src/plugins/contrib/wxSmith' make[3]: \*\*\* [distdir] Error 1 make[3]: Leaving directory/root/rpm/codeblocks/src/plugins/contrib’
make[2]: *** [distdir] Error 1
make[2]: Leaving directory /root/rpm/codeblocks/src/plugins' make[1]: \*\*\* [distdir] Error 1 make[1]: Leaving directory/root/rpm/codeblocks/src’
make: *** [distdir] Error 1

In fact , I have got the wxWidgets.tar.gz in the dir /opt/ untared, and use ./configure --make ----make install ,this has finished successsfully.

Also I use the wx-config --libs. wx-config --cXXflags, and make a soft link from /usr/inclue/gw-2.9/wx to /usr/include/wx

How did this happen, can anyone help me .

Thanks very much!!!