Install OF on Beaglebone Black

Hi

someone installed “OF” on “the Beaglebone Balck” ?

I have tried with "BBB-eMMC-flasher-debian-7.1-2013-08-24 " and “of_v0.8.0_linuxarmv7l_release”
and “Linux debian-armhf 3.8.13-bone20 armv7l GNU/Linux”

debian@debian-armhf:~/OF/examples/graphics/polygonExample$ df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 7.2G 1.4G 5.5G 21% / <-- installed on SDcard
/dev/root 7.2G 1.4G 5.5G 21% /
devtmpfs 248M 0 248M 0% /dev
tmpfs 50M 232K 50M 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 100M 0 100M 0% /run/shm
/dev/mmcblk0p1 1004K 472K 532K 48% /boot/uboot
/dev/sda1 1.9G 844M 1.1G 44% /media/usb

with this commands:

sudo apt-get install build-essential
sudo ./install_codeblocks.sh
sudo ./install_dependencies.sh
sudo ./install_codecs.sh

I have the same error
[color=black]debian@debian-armhf:~/OF/examples/graphics/polygonExample$ make
…/…/…/libs/openFrameworksCompiled/project/makefileCommon/config.shared.mk:259: *** couldn’t find some pkg-config packages, did you run the latest install_dependencies.sh?. Stop.[/color]

1 Like

Sorry to say that With the latest kernel

Linux arm 3.8.13-bone26 #1 SMP Sat Aug 17 00:43:59 UTC 2013 armv7l armv7l armv7l GNU/Linux

I GOt the same error…

I just installed oF 0.8.0 on the BBB with Ubuntu v13.10 (hard float). Here is how it went down. The following should work for most Ubuntu images but I started out with the one from the Lasersaur project.

  1. Install OS image

  2. Install Lasersaur Ubuntu image on BBB

  3. Then on the BBB through ssh:

  4. wget http://www.openframeworks.cc/versions/v0.8.0/of_v0.8.0_linuxarmv7l_release.tar.gz

  5. tar xzvf of_v0.8.0_linuxarmv7l_release.tar.gz

  6. cd of_v0.8.0_linuxarmv7l_release/scripts/linux/ubuntu

  7. sudo apt-get install libegl1-mesa-dev libgl1-mesa-dev libgles1-mesa-dev libgles2-mesa-dev libglu1-mesa-dev libosmesa6-dev libglw1-mesa-dev

  8. sudo ./install_dependencies.sh

  9. sudo ./install_codecs.sh

  10. cd ../../../

  11. echo -e "\n#define GL_STENCIL_INDEX GL_STENCIL_INDEX8\n" >> libs/openFrameworks/utils/ofConstants.h

  12. For this download oF should already be compiled. If not run: scripts/linux/compileOF.sh

  13. Getting the examples to work:

  14. always link against dl:
    echo -e "\nPLATFORM_LIBRARIES += dl\n" >> libs/openFrameworksCompiled/project/linuxarmv7l/config.linuxarmv7l.default.mk

  15. Then just take an example and modify main.cpp to run without window:

  16. cd ../../examples/graphics/imageLoaderWebExample

  17. make src/main.cpp look like this:

    #include “ofMain.h”
    #include “testApp.h”
    #include “ofAppNoWindow.h”

//========================================================================
int main( ){
    ofAppNoWindow w;
    ofSetupOpenGL(&w,1024,768, OF_WINDOW);                     // <-------- setup the GL context

    // this kicks off the running of my app
    // can be OF_WINDOW or OF_FULLSCREEN
    // pass in width and height too:
    ofRunApp( new testApp());

}
  1. make
  2. make run
3 Likes

I’ve installed a 3.12 kernel and the Graphics SDK for SITARA, I have the opengles accelerated examples running WITHOUT an X server.
I’ve also compiled OF in a headless manner.

Is there any way to run the examples using EGL on the accelerated framebuffer?

i guess we’ll need to adapt ofAppEGLWindow to work on the beaglebone since right now the version without x server is specific to the raspberry pi

It could be very useful to a lot of people I think.

I’m absolutely a beginner in either of Openframeworks nor OpenGl, but I have some experience with the BBB [but sadly not much time], so if someone is willing to start this task I can try help…

Yeah, as more boards like the Beaglebone, UDOO and ODROID series are released, having ofAppEGLWindow support them might come up more often.

Hi.

I’m considering OF to build a simple app in a Beagle Bone Black. Reading this discussion, it seems that one can run OF on such a device without a GUI and there is work yet to be done to get OF to run with a GUI without X server.

What about running a lightweight desktop environment like XFCE and running a “normal” OF app that opens in fulsscreen mode? is that possible? has anyone tried it? Debian, anyone?

Thanks!

Rafael.

Hi,

I’ve used the ubuntu-precise-12.04.3-armhf-3.8.13-bone30.img.xz (November 23, 2013) image for by bbb (Rev A5B). Upgraded to desktop ubuntu.

Done with sudo ./install_dependencies.sh a couple of times with no errors.

When i try to compile, I have the similar error.
ubuntu@ubuntu-armhf:~/Downloads/of_v0.8.4_linuxarmv7l_release/examples/3d/3DPrim
itivesExample$ make
checking pkg-config libraries: cairo zlib gstreamer-app-0.10 gstreamer-0.10 gstreamer-video-0.10 gstreamer-base-0.10 libudev freetype2 fontconfig sndfile openal openssl libpulse-simple alsa gtk±3.0 libmpg123 glesv1_cm glesv2 egl
…/…/…/libs/openFrameworksCompiled/project/makefileCommon/config.shared.mk:260: *** couldn’t find some pkg-config packages, did you run the latest install_dependencies.sh?. Stop.

Anyone solved this?

I had the exact error earlier with my raspberry pi 2. The solution was to set the environmental variable and automate it in bash.
export MAKEFLAGS=-j4 PLATFORM_VARIANT=rpi2.

Any thoughts if this would be a similar approach for bbb ubuntu precise LTS?