image will not load

this is weird to me…

I have perfectly working code that works ok with 4 jpg images

Then I change this 4 jpgs with 4 other jpgs (of higher resolution and size) - and the code does not work anymore ! I can see nothing but a white rectangle in the place that the images were supposed to be…

this has nothing to do with locating the files - I double checked the names and I even tried to rename (via copy-pasting) using the name of the original working jpg

may I assume that openFrameworks only load files with certain characteristics ?? if so, what resolution/compression/etc should I use ??

m

post your code, it could be helpful for us to help.

guess: do you allocate your images right for the new size?

Perhaps you are hitting max texture size with your hires-images. What sizes are they?

I did not explain it well - the images I want ro replace are identical with the exception that the resolution is higher. I was given 4 test images to develop a project and now they gave me the proper hi-resolution ones to proceed to the final version - the dimensions are exactly the same

however of faisl to show them

my code is really simple and straightforward but part of a quite complicated (and lengthy) project so it is impossible to post everything here…

the crucial part is that simple

in setup:

  
	  
base.loadImage("00_Arbitrariness_mariaPaschalidou.jpg");  
	img1.loadImage("01_Arbitrariness_mariaPaschalidou.jpg");  
	img2.loadImage("02_Arbitrariness_mariaPaschalidou.jpg");  
	img3.loadImage("03_Arbitrariness_mariaPaschalidou.jpg");  
	  
	baseRatio = 1.5*ofGetWidth()/base.getWidth();  
	img1Ratio = ofGetHeight()/img1.getHeight();  
	img2Ratio = 1.6*ofGetWidth()/img2.getWidth();  
	img3Ratio = 1.55*ofGetWidth()/img3.getWidth();  
	  

in draw:

  
float imgX = ofGetWidth()*0.5-base.getWidth()*baseRatio/2;  
		float imgY = ofGetHeight()*0.5-base.getHeight()*baseRatio/2;  
		float imgW = base.getWidth()*baseRatio;  
		float imgH = base.getHeight()*baseRatio;  
				  
		// image  
		// ofSetColor(255,255,255);  
		base.draw(imgX,imgY,imgW,imgH);  

their sizes are approximately 40-50MB - what is the max size allowed and what is the best solution in this case ??

what is the size of the images in pixels?

16535?×?5532

googling a little the max tex size i can find is 16384, try resizing to that size to see if it works, if it does then is related with the max size supported by the graphics card

thank you - I’ ll be on vacation for a couple of days but will come back to this right after and let the forum know

Nope… no good…

I even tried saving under different file format (tiff) but no luck either…

I am pretty overwhelmed, what else could be wrong ?? They are just normal high-quality jpeg…

could it be their size ?

I cannot understand this, I just used the original images and it’ s ok - the only thing that changes is the resolution…