HOWTO install gstreamer on ubuntu 8.10??? need help please

hi all
i am using ubuntu 8.10 and can not change my version because i have other program need 8.10.
i try to install OF on ubuntu8.10 and follew this link
http://forum.openframeworks.cc/t/problem-installing-with-ubuntu-hardy/3282/0
and stop in last step then i install gstreamer
$ pkg-config gstreamer-0.10 --cflags
-pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2

i thing gstreamer installed ok
but when i try to install OF the following error happend

In file included from …/…/…/openFrameworks/video/ofGstUtils.cpp:3:
…/…/…/gstappsink/include/gst/app/gstappsink.h:106: error: ISO C++ forbids declaration of ‘GstBufferList’ with no type
…/…/…/gstappsink/include/gst/app/gstappsink.h:106: error: expected ‘;’ before ‘*’ token
…/…/…/gstappsink/include/gst/app/gstappsink.h:107: error: ISO C++ forbids declaration of ‘GstBufferList’ with no type
…/…/…/gstappsink/include/gst/app/gstappsink.h:107: error: expected ‘;’ before ‘*’ token
…/…/…/gstappsink/include/gst/app/gstappsink.h:131: error: expected constructor, destructor, or type conversion before ‘*’ token
…/…/…/openFrameworks/video/ofGstUtils.cpp: In member function ‘void ofGstUtils::setSpeed(float)’:
…/…/…/openFrameworks/video/ofGstUtils.cpp:1035: error: ‘GST_SEEK_FLAG_SKIP’ was not declared in this scope
make: *** [obj/Debug/…/…/…/openFrameworks/video/ofGstUtils.o] Error 1
there has been a problem compiling Debug OF library
please report this problem in the forums

now please i need your help to install OF because i need it very much.
thank you

hi, perhaps the easiest solution is to use 006. that version is compatible with 8.04

http://www.openframeworks.cc/versions/p-…-FAT.tar.gz

it’s in the download page under the examples screenshots

anyway, this:

$ pkg-config gstreamer-0.10 --cflags
-pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2

doesn’t install gstreamer.

if you really need to install 0061, you can try asking the gstreamer specific questions in the gstreamer list. i don’t really know how to install gstreamer in an specific ubuntu version or if it’s possible at all because of incompatibilities with other libraries versions.

thank you very much
i realy do not know which is sutible for video streaming v0.061 or v0.06
if v0.06 is work ok in video i have no problem and using it

now i will try to install v0.06 and back you.

thank you

I too would suggest using 60 and not 61. 61 is far to painful to get working on hardy.

Hello everyone,

I was wondering… Does this also apply to an installation of 0.61 on ubuntu 9.04?

I tried this morning for fun, and got the same error message while running the install_dependencies script.

regards

david

in 9.04, you can install a newer version of gstreamer without problem using this ubuntu ppa:

https://launchpad.net/~gstreamer-develo-…-rchive/ppa

just go to system > administration > software sources and add this repositories:

deb http://ppa.launchpad.net/gstreamer-deve-…-ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/gstreamer-deve-…-ppa/ubuntu jaunty main

works like a charm. Thanks a lot for sorting me out.

regards

david