I remember i had a collision with ofArduino. Not sure if that is your case. but i remember the error was not quite obvious.
There is a macro that has the same name in both sides. so i renamed the ofArduino side. I must fill out a bug in github.. but i guess this only affects us, working with Qt... not sure how are the politics when solving this kind of things...
look at libs/openfrmaeworks/communication.ofArduino.h
#define SHIFT 0x05 // shiftIn/shiftOut mode
deactivate it or rename it and let me know.