How to send AT Commands?

So I bought this board SM5100B-D from sparkfun

Here is the documentation

When I open the serial example the device appears first in line:
[notice ] ofSerial: [0] = tty.usbserial-A601EWHI
[notice ] ofSerial: [1] = cu.usbserial-A601EWHI

any feedback around this?
how do I communicate with this thing? any ideas?

should I use standard firmata?
or this addon?

I tried this:

This lad tried to write a library for arduino:

more good stuff here:

Hi, it should be quite straight forwards.
you need to write through serial a string that starts with "AT" and ends with "\r\n"
the document you linked has all the available AT commands.
did you tried the included ofSerial? or ofxSerial?
cheers

Yeah, I am giving it a go right now,

What I don’t understand about his code, is what is the difference between Serial
and softwareSerial class…

I assume softwareSerial will be the equivalent of ofxSimpleSerial for us so I made the changes

but Serial.println is an Arduino class

and in the code it seems like he is using it to take feedback?

I am going to try a simpler approach first using ofxSerial

ah… curse… ofxSerial & ofxIO seem to be broken on my OF version (0.9.6)

I don’t have hard drive space on this machine to download the current version, I am going to try do it with ofSerial or ofxsimpleserial instead…

I think ofxSerial is officially broken, I tried to link it on latest branch
using the VS project generator and got 6318Errors…

is there another way to test the module?
it opens, it writes but no ouput
[notice ] ofSerial: opening /dev/tty.usbserial-A601EWHI @ 9600 bps
[notice ] ofSerial: opened /dev/tty.usbserial-A601EWHI sucessfully @ 9600 bps
[verbose] ofSerial: wrote 4 bytes

is there a way from terminal or an app or something to test that this thing is actually communicating with the SM5100B-D? (i tried PuTTY) but it doesn’t even let me type anything

maybe this shield is designed in such a way to only return data via the pins?

so it needs an arduino to work?

I have a duemilanove somewhere … but all the examples i see around work with UNO…

I tried this, and still didn’t get anything from the board…

lol… so I followed these instructions: but with 9600

and got a “b”:

a capital B that is…
int putty I got this:

another B…

??any ideas what does it mean? b like broken or B like boss?

well that’s 100 bucks down the toilet…

I am thinking of buying this one now:

option 2

or this?

fyi… twilio does not support sms where I live…

Hi,
well there are several things about this.
First. arduinos software serial is not the same as ofxSimpleSerial.
When you want to send serial data through a port, this data needs to get arranged in a certain way and outputed with a certain timing. software serial does all these things via software, while regular serial does it in specialized hardware. Using software serial you can input and output serial from any arduino digital pin, while with regular serial you only have pins 0 and 1 in the UNO.

Putty is actually a good choice for testing. much easier than using OF.
in the documentation of that board you have a reference of the available commands and what to expect in return of each one.

1 Like

Hi Roy,

I think they sold me a broken GSM board
I tried Terminal, Putty, and other approaches, the board is 99.9% dead.

It returns a “B”

I am tempted to test it via arduino but I prefer to limit adaptors and dongles…

I will try again on Monday with some old Nokia phones, till I get my new board

Uhh that so bad! :angry:

good luck with the new board. don’t hesitate on asking here if you need more help.