How to force opengl2.x renderer in OF 0.8

Hi all

I saw that one can force fixed pipeline renderer in the main of the app by not calling ofSetCurrentRenderer

  
  
//#define USE_PROGRAMMABLE_RENDERER  
  
#ifdef USE_PROGRAMMABLE_RENDERER  
#include "ofGLProgrammableRenderer.h"  
#endif  
  
//========================================================================  
int main( ){  
  
#ifdef USE_PROGRAMMABLE_RENDERER  
    ofSetCurrentRenderer(ofGLProgrammableRenderer::TYPE);  
#endif  
      
	ofSetupOpenGL(640*2,480*2, OF_WINDOW);			// <-------- setup the GL context  
      
	// this kicks off the running of my app  
	// can be OF_WINDOW or OF_FULLSCREEN  
	// pass in width and height too:  
	ofRunApp(new testApp());  
  
}  
  

But I’m not sure that switch back to opengl 2.x ?

I need to get a working of 0.7/opengl 2.x application to works in OF 0.8 but with an opengl version lower than 3.x

thanks for help

if you remove the call to set the programmable renderer OF will default to openGL 2

ok thanks a lot for the precision

my shaders don’t work anymore, I’ll dig to figure out why.

they don’t compile or they don’t do what they should be doing?

they don’t do what they expected to do :

update a texture by gl_FragData

not sure what can be going on, perhaps it would be useful if you could post a small example that was working on 0074 and not in 080

Okay here’s a simpified version of the code

http://dl.free.fr/eoERKoCGW

I’ve integrated opencloth lib
In OF 0.7 the result is a smoothly animated swiss flag
but in OF 0.8 it’s a black screen even by forcing opengl 2