How to fix OF build in Xcode 13.0

Just downloaded Xcode and it won’t compile OF projects.
It gives an error on Prepare build saying - The Legacy Build system will be removed in a future release.

Is this the release where it has gone?

Can you check in Xcode:

  • Under File → Project Settings… that you are not using the Legacy Build System and you have New Build System selected.

Also is this with OF 0.11.2 or an older project?

If the above doesn’t resolve it, can you post the full error. ( Ctrl click on the error and select Open In Build Log )

Thanks!
Theo

4 Likes

Thanks,
Yes I am using OF 0.11.2 and that will fix several of the examples I have tried from the examples folder.

However, I did write by own app based on the ofBook’s :- Ooops! = Object Oriented Programming + Classes tutorial which did work and that is not fixed by this change.
I got four errors about not being able to find files.
The full error messages are in the attached file:-

Errors.zip (2.7 KB)

However I spotted that there are what seems to be matching warnings for each error.

  1. Building targets in manual order is deprecated - check “Parallelize build for command-line builds” in the project editor, or set DISABLE_MANUAL_TARGET_ORDER_BUILD_WARNING in any of the targets in the current build to suppress this warning

  2. Skipping duplicate build file in Compile Sources build phase: /Users/mikecook/Documents/OpenFrameworks/of_v0.11.2_osx_release/libs/openFrameworks/app/ofBaseApp.cpp (in target ‘openFrameworks’ from project ‘openFrameworksLib’)

  3. Skipping duplicate build file in Compile Sources build phase: /Users/mikecook/Documents/OpenFrameworks/of_v0.11.2_osx_release/libs/openFrameworks/app/ofBaseApp.cpp (in target ‘openFrameworks’ from project ‘openFrameworksLib’)

  4. Traditional headermap style is no longer supported; please migrate to using separate headermaps and set ‘ALWAYS_SEARCH_USER_PATHS’ to NO. (in target ‘openFrameworks’ from project ‘openFrameworksLib’)

Do you know how these could be corrected. I did have a look round but didn’t see anything.
Thanks again

So what I had to do to solve this was to basically create the files I had created, ofApp.cpp and ofApp.h in the project again using Xcode.

Then I could take the original files I had created and copy and paste the contents of these files and the others I had modified to match. That and changing the build system solved the problem.
Thanks @theo.