How do I use c++11 in codeblocks?

Hello everyone, I guess the title of the post is pretty self explanatory, so, all I know is codeblocks is telling me if I want to use c++11 I have to compile with -std=c++0x or -std=gnu++0x options.
I know that if I were to compile my program from the terminal that would mean I’d have to use the command gcc -std=c++0x, or (-std=gnu++0x), but how do I do this in codeblocks? Im completely new to codeblocks, please help!

in linux you don’t need to configure codeblocks, just open the config.make file and add those flags in CFLAGS

Hey thanks a lot arturo!, that worked, now I can use all of the new c++11 goodies :wink:

this is my first post here and I don’t wanna be a bummer but just using the -std=c++0x flag works, I tried it on the emptyExample project and now it doesn’t compile, codeblocks throws the following errors it found in ofTypes.h:

-------------- Build: Debug in emptyExample ---------------

Using makefile: Makefile
Compiling OF library for Debug
Done!
Compiling emptyExample for Debug
Compiling src/main.cpp
In file included from …/…/…/libs/openFrameworks/utils/ofLog.h:5:0,
from …/…/…/libs/openFrameworks/ofMain.h:7,
from src/main.cpp:1:
…/…/…/libs/openFrameworks/types/ofTypes.h:13:18: error: ‘shared_ptr’ is already declared in this scope
…/…/…/libs/openFrameworks/types/ofTypes.h:14:18: error: ‘weak_ptr’ is already declared in this scope
…/…/…/libs/openFrameworks/types/ofTypes.h:15:18: error: ‘enable_shared_from_this’ is already declared in this scope
make[1]: *** [obj/linux64/Debug/src/main.o] Error 1
make: *** [Debug] Error 2
Process terminated with status 2 (0 minutes, 4 seconds)
3 errors, 0 warnings

we added some code in 0.7.4 that broke compatibility with c++11 using this flags, there’s an ifdef in ofTypes that requires the definitive version of c++11 instead of the experimental one so now to be able to use c++11 you need to add:

  
  
PROJECT_CFLAGS = -std=c++11