Help with glm.hpp error

Hi, i’ve cloned OF from github, then cloned projectGenerator, build the, generated a project.
When I try to run it, I get 'glm/glm.hpp' file not found error.
I’m on mac 10.11.6 with xCode 8.2
Any suggestions how to solve it?

you need to run first the scripts/osx/ it’s explained in the readme

Hey thanks, but I can’t find this on github page, what readme file are you referring to?

the one on the git download:


I have the same error, also after running

glm/glm.hpp “file not found”

This only happens to me if I try to use the github master instead of the osx specific install

Thank you for any advice

can you post the output of running the download_libs script

fubbi:osx fubbi$ sudo ./
Downloading openFrameworksLibs_master_osx1.tar.bz2
–2017-01-27 15:07:52--
Resolving (…
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 12322349 (12M) [application/octet-stream]
Saving to: ‘openFrameworksLibs_master_osx1.tar.bz2’

openFrameworksLibs_ 100%[===================>] 11.75M 2.22MB/s in 6.1s

2017-01-27 15:07:59 (1.92 MB/s) - ‘openFrameworksLibs_master_osx1.tar.bz2’ saved [12322349/12322349]

Downloading openFrameworksLibs_master_osx2.tar.bz2
–2017-01-27 15:07:59--
Resolving (…
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 7166870 (6.8M) [application/octet-stream]
Saving to: ‘openFrameworksLibs_master_osx2.tar.bz2’

openFrameworksLibs_ 100%[===================>] 6.83M 1.92MB/s in 4.0s

2017-01-27 15:08:03 (1.69 MB/s) - ‘openFrameworksLibs_master_osx2.tar.bz2’ saved [7166870/7166870]

Downloading openFrameworksLibs_master_osx3.tar.bz2
–2017-01-27 15:08:03--
Resolving (…
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 18161457 (17M) [application/octet-stream]
Saving to: ‘openFrameworksLibs_master_osx3.tar.bz2’

openFrameworksLibs_ 100%[===================>] 17.32M 1.75MB/s in 12s

2017-01-27 15:08:16 (1.40 MB/s) - ‘openFrameworksLibs_master_osx3.tar.bz2’ saved [18161457/18161457]

Removing old libraries
Uncompressing libraries osx from openFrameworksLibs_master_osx1.tar.bz2
Uncompressing libraries osx from openFrameworksLibs_master_osx2.tar.bz2
Uncompressing libraries osx from openFrameworksLibs_master_osx3.tar.bz2
Copying opencv to ofxOpenCv
Copying assimp to ofxAssimpModelLoader
Copying libxml2 to ofxSvg
Copying svgtiny to ofxSvg
Copying poco to ofxPoco
Copying openssl to ofxPoco

So i got rid of the error. No idea how to do all this stuff, just n00b brute force.

previous method (generates the error): download zip of github master

long way round (no error)

  1. I registered with github and forked the ofx master, downloaded and installed git, git desktop (gui) and wget.
  2. Cloned the entire openFrameworks repo.
  3. Ran the script in terminal (works after installing wget)
  4. Used the project generator from the osx openframeworks download (there is none in the master repo) to update all the example folders.
  5. Compiling the examples works!

great to hear. also if you don’t need the git version but want to have the latest changes you can always use the nightly builds from the downloads page which have all the latest changes and also include the libraries and examples project files so it’s easier to use

why i couldn’t find the in the script/osx folder? i downloaded of_v0.9.8_osx_release from is it something doesn’t need to do in this version of openframeworks?

this is only needed when using openframeworks from github not from the web downloads

1 Like

thanks @arturo for the answer, I resolved the error using stable branch of ofxCv instead

I’m having difficulties with the same issue but in Windows (10).
I’m running the script from ConEmu and i had to download wget install it and copy it to c:\Program Files\Git\mingw64\bin\. Now the output does not complain anymore but I dont know what else i have to do.

current output:

Jordi@Jordi-PC /c/openFrameworks/scripts/vs [myOfMaster] $ .
Jordi@Jordi-PC /c/openFrameworks/scripts/vs [myOfMaster] $

BTW i can’t find the downloaded file.

Any idea?

the .sh script is only tested with the msys2 console. if you don’t want to install it then the .ps script can be run by windows itself without any additional software but you might need to enable some permissions

1 Like

Thank you so much for the fast reply! powershell worked perfectly.
Everything up an running again!