Having trouble with Linux install on Ubuntu 16.04 LTS

#1

I don’t think mine is a third party distribution, so I don’t think the errors I’m getting are because of that. When I run scripts/linux/ubuntu/install_dependencies.sh, I first get a few “service unavailable” and “The following signatures couldn’t be verified because the public key is not available” errors followed by “Some index files failed to download. They have been ignored, or old ones used instead.” I don’t know how much of a problem this is.

I then answer “Yes” to the question “Your system is not updated, that can create problems when installing the OF dependencies. Do you want to update all the packages now?”, after which I get a large number of ROS packages saying they “failed to fetch” and “service unavailable”. I am not sure if I should try to fix this or of updating the system is really necessary - maybe I should just answer “No”?

Then when installing dependencies, I also get the following error:

Installing libgl1-mesa-dev-hwe-16.04
E: Unable to locate package libgl1-mesa-dev-hwe-16.04
E: Couldn’t find any package by glob ‘libgl1-mesa-dev-hwe-16.04’
E: Couldn’t find any package by regex ‘libgl1-mesa-dev-hwe-16.04’
error installing libgl1-mesa-dev-hwe-16.04
Reading package lists… Building dependency tree… Reading state information…
this seems an error with your distribution repositories but you can also
report an issue in the openFrameworks github

I’m not sure what “error with your distribution repositories” means I should do.

#2

can you try using the nightly builds instead of the normal download? the problem with the hwe packages should be solved there. the problems about public key not being available sound like you are just having problems with how your repositories are set though

#3

Ok, I tried following the install_from_github instructions, but whenever I try to compile the examples using the ProjectGenerator app (I copied in the projectGenerator folder from the release version), it says “Error: there was a problem updating your project.” The stack trace screenshot on the error message says “exec format error”. If I try instead to use the command line version from the root directory, it says it doesn’t recognize the command projectGenerator.

#4

Also just to do a quick test I installed libfreenect2 on its own, and it cannot seem to find my Kinect v2 device even when it’s plugged in - since openFrameworks kinect addons use libfreenect, is it even worth trying to finish the installation if libfreenect2 doesn’t work in isolation? Having trouble figuring out why it’s not detecting the Kinect in the first place.