Hardcore error :-(

Hi,

I didn’t change anything in my project, except the code itself which I thought it was the cause of a strange error.
I undo all my changes, til the same.
I copy paste from a previous backup, til the same

The error is a crash at the application test in the simulator (iOS 5)
I also have a strange warning and this one doesn’t seem to be here yesterday :-/

Is it possible that, FOR STRANGE UNKNOWN REASON for me, the project itself (xcode project file) has been corrupted by a process, something?

I mean, I can really be the cause, but I don’t know why it worked, it doesn’t if nothing has changed in my code :-/

It looks like you’re somehow pointing at the non-simulator version of the GL library, i.e. the one meant to be running on the iPhone, not your computer. I’m not sure how that happens and I don’t know the internals of building things for the iPhone so well, but I’d just make sure that both the project and target are set to Simulator and i386 not ARM7

hi joshua, and many thanks for your answer
ok I got it

why does it happen ? is THE question
if this happens again, how I can easily fix it?

in the meantime, I worked around that copying manually my code into a new safe emptyexample project :slight_smile: