gstreamer 0.10?

the install script should recognize that gstreamer 1.0 is available on your system: https://github.com/openframeworks/openFrameworks/blob/master/scripts/linux/ubuntu/install-dependencies.sh#L17-L23
something must be going wrong.

what’s your output of 1) “apt-cache policy libgstreamer1.0-dev” and
2) “apt-cache show -n libgstreamer1.0-dev”, then “echo $?” ?

thank you.
re 2) - the “echo $?” command has to be entered after the “apt-cache show…” command, and will give us the return status of the previous command (0 or 1 most probably), based on which the gstreamer version is selected (and which seems to be malfunctioning in your case).
you do have the “echo” command on your system, right? what happens if you enter “echo test” on the command line?

this is strange, this would correctly select gstreamer1.0., so I don’t know why it complains about not finding 0.10.
could you post the output of your install_dependencies.sh script (in http://pastebin.com/ or similar), at least until it starts compiling the core library, or fails and stops?

I’ll ping arturo, maybe he knows what’s going on here.

this must be the wrong link :wink:

Hi. I have similar problem with gstreamer on ubuntu 12.10, with OF 0.7.4.
Simple solution for me was:

  • download OF 0.7.3,
  • call its
    sudo ./install_codeblocks.sh
    sudo ./install_dependencies.sh

Then OF 0.7.3 works, and, also, 0.7.4 works too!

(During installing I saw that script just install gstreamer 0.10 correctly, in 0.7.3)

I had the same problem with gstreamer 0.10 in Lubuntu 12.10 and just made it work.

The problem is in the Makefile. Go to the folder openframeworks_074/libs/openFrameworksCompiled/project/linux and open it.
In line 117 :

CFLAGS += $(shell pkg-config gstreamer-0.10 gstreamer-video-0.10 gstreamer-base-0.10 libudev glew --cflags)

you should amend the version of gstreamer with the one you installed (1.0 in my case…)
Hope it helps…Good luck!

Thank you! It works great!!!
I installed the dependencies with this command.
apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev
I can compile and execute some examples but cameraLensOffsetExample or opencvExample weren’t been able to compile because the computer can’t find gst_* methods.

Hi, same problem here, on Lubuntu 12.10.
gst/gst.h not found.

Following SoisDeTraca solution works fine.