graphics card FBO & VBA problem

hi

ive got a HP-dc5800 Intel Core 2 Duo E7400 2.8GHz (with upgraded power supply) & integrated graphics.

I have an Nvidia GeForce 9800 GTX+ (link) and have updated to the latest drivers, which supports OpenGL 3.0 specification.

I downloaded this opengl extension & version viewer, it shows that i have opengl 3.0 and that both frame buffer objects and VBAs are supported.

However when I try and run either (fbo addon or vba test) using openframeworks, it says that the graphics card doesn’t support them (or it crashes).

Does anyone have any ideas what could be going wrong?

Thanks

vista? xp ?

I’m guessing our version of GLEE is out of date?

http://elf-stone.com/glee.php

It looks like we have : Version : 5.21
and the most recent version is : 5.4

can you try just swapping the newer library for the older one?

while I don’t have cb in front of me, but maybe you have to compile the src for cb? (the lib could be vs specific, I’m not sure offhand).

take care,
zach

alternatively, to test, remove the glee linking for the project and just add GLee.h and GLee.cpp from the newer library to you project…

take care,
zach

hey zach, thanks!

(codeblocks xp pro)

i downloaded glee 5.4, and put GLee.h and GLee.c into openframeworks\v0.06\libs\glee\include, added both files to my project and removed the link to .lib

This is my build log…

[edit] - sorry, i should have cleaned my project as of course it breaks the shader addon. will put on this 2nd machine and let u know.

what a nightmare, ive built the app using the new glee (not the lib) and when i run it on this machine i get the same error from ofxShader.

Very weird.

I’ve tried the ogre3d demos and those 3d demos from the glee site and they all work.

Any thoughts?

thanks

i dont know if this is relevant, but I have no problems running fbos and vbos and va’s on an ATI X1600 on windows xp sp3 using codeblocks (macbook pro running in bootcamp). Would this rule out any problems with glee version?

I think it would only rule it out if your graphics card was opengl 3.0

can you ouput glee’s extensions, ie:

  
  
printf("extensions that GLEE can use: \n %s \n", GLeeGetExtStrGL());  
  

you should get a list, like:

  
  
extensions that GLEE can use:   
 GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_vertex_blend GL_ARB_window_pos GL_ARB_shader_objects GL_ARB_vertex_shader GL_ARB_shading_language_100 ........  
  

can you paste that in?

take care,
zach

might also be useful :

  
GLeeGetErrorString()   

to try after a line that doesn’t work – maybe it says something?

  • zach

is there a glee command to list the system graphics info, such opengl version, or which hardware?

the extensions list only has 3 things in. im wondering if its trying to use the integrated graphcis card, even though its been disabled.

looks like that’s the case. actually – I think the problem is lower then glee

from there readme “By default, only those extensions reported by OpenGL’s
glGetString(GL_EXTENSIONS) are loaded by GLeeInit()”

you might check out the section:

“FORCED EXTENSION SUPPORT” which seems like it would do the trick for you.

alternatively, you might try:

a) try glGetString(GL_EXTENSIONS) and see if it’s also thin as the glee
b) ask on the opengl forum (opengl.org) about this

I just did some quick google searching, but didn’t come up with much. check also the drivers for the card you are running and see if there is a more recent one.

take care!
zach

ps: here’s someone that might have had the same problem as you?

http://newsgroups.derkeiler.com/Archive-…-00152.html

You’d say that, but I had the guy check with ‘wglinfo’ and that showed only 2 extensions, see also the post from Cathy.
Now I remember also having come across the machine, and I installed an nVidia driver a few times without avail, then I checked Control Panel, and there was an extra driver (Asus then presumably); after uninstalling the lot, rebooting and installing the nVidia one, things were fine again.

Drivers! !:#!@#$#% :wink:

also, this looks like an alternative to glGetString(…) that opengl 3.0 specific :

  
  
GLint n, i;  
glGetIntegerv(GL_NUM_EXTENSIONS, &n);  
for (i = 0; i < n; i++) {  
printf("%s\n", glGetStringi(GL_EXTENSIONS, i);  
}  
  

and useful opengl reporting code:

  
  
printf("GL_RENDERER = %s\n", (char *) glGetString(GL_RENDERER));  
printf("GL_VERSION = %s\n", (char *) glGetString(GL_VERSION));  
printf("GL_VENDOR = %s\n", (char *) glGetString(GL_VENDOR));  
printf("GL_EXTENSIONS = %s\n", (char *) glGetString(GL_EXTENSIONS));  
  

hey

thanks for all your help.

the output of those printf was showing that it was using a basic driver with opengl 1.1, strange though that other demos worked ok.

I installed the intel integrated drivers, booted into safe mode, uninstalled nvidia, then restarted and installed nvidia again, now it all works, hurray.

The previous glee stuff still works, it was just picking up the wrong card. Do you think we should update glee for 0061?

cheers

did you disable the integrated graphics from the bios in the end? did it make any difference?

no, i couldnt find the option in the end. just uninstalled the integrated drivers and nvidia drivers, then installed again.