Getting stream from mjpeg-streamer?

Anyone found a way to get the stream from mjpeg-streamer?
I’ve looked at the axis mjpeg add ons but they don’t work with mjpeg-streamer.

I have the streamer working well from a Raspberry pi and I can play it in pretty much anything apart from OF.

For example it loads into VLC player like this:
http://raspberrypi.local:8080/?action=stream

Thx.

https://github.com/bakercp/ofxIpVideoGrabber works.

Thanks - I’ve tried your excellent cam grabber/player and it can read axis cams off the web ok, but
if I add:
http://raspberrypi.local:8080/?action=stream

as an XML line to the demo file
it quits as soon as I compile with an error saying it can’t read that camera.(of 0.9.8 OSX 10.11.6)
[ error ] Unable to load streams.xml.

Is there a way to make it parse this line?

Hey there, it looks like your error may be because it can’t find the streams.xml file for some reason.

Anyway, I just tested and updated the addon for the master branch of openFrameworks. It’s working fine with mjpeg-streamer. Just put the http://raspberrypi.local:8080/?action=stream in here

Hi Chris - thanks for looking at this.
Just to be clear, the original example did find the .XML file and worked with the addresses within.It was only my RPI mjpeg-streamer address it did not like.
The new example won’t run as it keeps asking for ‘json.h’ even though I seem to have this header in the openFrameworks folder.
Do I need the master branch of OF to work with this? or some other json addon?Tried this before if you remember and I had all those Json issues with ofxHTTP (which is now fine with all the stable branches)
Best Regards,Ian

The “unable to load streams” message makes me think there is an error parsing the XML.

Can you check your XML file with an XML validator?

Regarding my updated version, the stable branch corresponds to 0.9.8. the master branch corresponds to the oF master branch.

Thanks for your help Chris - The XML seemed fine when validated. I am back testing the stable version with 0.9.8However… what was happening was that the double-quote characters were not being accepted.(or getting corrupted somewhere)
I’ve seen this before - sometimes on OSX the quotes get swapped from the ones that look symmetrical(linux?) forthe ones that look like 66 99.
Anyway the 0.9.8 stable works well.
I did quickly look at the master with OF master branch but it produced the error shown below ( don’t really need master but FYI if needed)
Best Regards,Ian.
OF master and using your new master but get these errors:/Users/ian/Downloads/openFrameworks-master/addons/ofxIpVideoGrabber/example/src/ofApp.h:27:17: No type named ‘IpVideoGrabberSettings’ in namespace ‘ofx::Video’/Users/ian/Downloads/openFrameworks-master/addons/ofxIpVideoGrabber/example/src/ofApp.h:28:29: No member named ‘IpVideoGrabberSettings’ in namespace ‘ofx::Video’/Users/ian/Downloads/openFrameworks-master/addons/ofxIpVideoGrabber/example/src/main.cpp:14:12: No matching function for call to ‘ofRunApp’/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/include/c++/v1/memory:4311:18: Assigning to ‘std::__1::__shared_weak_count *’ from incompatible type ‘pointer’ (aka ‘std::__1::__shared_ptr_emplace<ofApp, std::__1::allocator > *’)

thank you!the first address still works