Getting started with Qt Creator on Linux

I am getting started with OF on linux (ubuntu 16.04) and I am having issues setting up the Qt Creator IDE.

When I install the most up to date version of QT I get the following error:

error: Package libmpg123 was not found in the pkg-config search path.
Perhaps you should add the directoru containing ‘libmpg123.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘libmpg123’ found

I assume I should migrate back to 3.6.1 or 3.5.1. However these version aren’t available on the archives for some reason: http://download.qt.io/archive/qt/3/

I suppose I could use 3.3.8 but I suspect I will come across issues with this older version as well.

Any guidance on how to resolve the issue with the latest version or how to find a copy of 3.6.1?

hello,

yes i also ran into several issues with qtcreator under ubuntu 16.04, latest version (4.0) as well with the previous versions…

version 3.5.1 is in the repositories no ?

Anyway you should be good with those links :

Version 3.5.1
http://download.qt.io/official_releases/qtcreator/3.5/3.5.1/

Version 3.6.1
http://download.qt.io/official_releases/qtcreator/3.6/3.6.1/

@Caroline_Record i ran into that error yesterday. The solution is to run the install_codecs.sh script in your linux flavor folder (scripts/ubuntu in my case).

It also happens with QT 3.6.1

Thank you for the help! Installing the codecs and switching to 3.6.1 worked for me. When I just installed the codec 5.7 still didn’t work. I got the “maximum call stack exceeded” error.

3.6.1 works, although I made the mistake of installing it before uninstalling 5.7. After using the "maintenance
tool’ to uninstall and then reinstalling 3.6.1 it all worked fine.

For some reason 3.6.1 is not linked to through QT’s archive. So the link to the official releases was very helpful.

I think that the github version (post 0.9.3) is now compatible with more recent versions of QT.

I was experiencing the same problem. I can confirm that the latest Github version works with the most recent QtCreator on Unbuntu 16.04.