Getting QtCreator to work on Windows

I’m trying to get Qt to work on windows but with no luck.

The Msys2 is different than in the install instructions, MinGW is not in the msys64 folder, it’s installed in it’s own folder. And on my machine I didn’t have the make command. I downloaded GnuWin32 from the msys2 site, and I got make to work, but when trying to run make in openFrameworksCompiled/project, I get this error:

$ make
HOST_OS=MINGW64_NT-10.0
HOST_ARCH=x86_64
checking pkg-config libraries: zlib openssl glew
/usr/bin/sh: /mingw32/bin/pkg-config: No such file or directory
makefileCommon/config.shared.mk:278: *** couldn’t find some pkg-config packages, did you run the latest install_dependencies.sh?. Stop.

The folder named win_cb is missing from the downloaded Qt version of oF, so I can’t do this:
cd your_oF_directory/scripts/win_cb/msys2
./install_dependencies.sh`

But I tried the same for the msys2 and qtcreator folders, but still no luck.

Besides, in QtCreator, when setting ut the compiler, it’s not possible to set the bin folder, only files are to be chosen. What file should I choose here?

It would be great if the oF team could update the setup guide for Qt on Windows!
I’m on W10 by the way.

I wanted to try oF with Qt, but why so much hassle?

Thanks for any reply!

Tommy

You can solve that by using latest nightly build there is an error in config.shared.mk in windows related lines of code. See here what errors you will find after:

Maybe GnuWin32 will solve my code 2 error.

Seems OF developers do not have a windows machine.