Getting ofxFaceTracker to compile in Xcode

It took a lot of work to get ofxFaceTracker examples up and running so I thought I’d share the steps that worked for me. I’m new to both OF and Xcode so if I’m doing anything wrong your corrections are much appreciated!

OSX 10.7.5, Xcode 4.4.1, OpenFrameworks 0072.

First, I cloned ofxCv, ofxFaceTracker from GitHub into the OF/addons folder.

This is the weird step: I moved the example folders out of ofxFaceTracker into OF/examples/addons. I had to do this to prevent a bunch of linker duplicate symbol errors, e.g., “ld: duplicate symbol _main”.

Looks like the reason for this is that the example src/ folder was being processed twice. However, the examples in ofCv worked fine from within the addon directory so I’m probably missing something here.

Next I opened the empty example xcodeproj file in Xcode. Changed the scheme to ofApp Debug.

Then I dragged the ofxCv, ofxFaceTracker, and ofxXmlSettings addon folders from Finder into the addons group in Xcode’s project navigator.

Finally, under the Build Settings I added a couple of Header Search Paths:
…/…/…/addons/ofxFaceTracker/libs/FaceTracker/include
…/…/…/addons/ofxOsc/libs/oscpack/src

And that was it! I was so happy to see that ‘Build Succeeded’ message. Hope this helps some one. (-:

hey! i just updated the project files, they should work again. if you have issues in the future post a problem to github and i can address it faster.

Hi there,

i downloaded the latest version of facetracker, followed all intructions (add ‘bin/data/model’ folder in the example folder) and i still have issues :

[font=Verdana]Command /Applications/Xcode.app/Contents/Developer/usr/bin/llvm-gcc-4.2 failed with exit code 1

…/libs/FaceTracker/src/lib/CLM.cc: No such file or directory[/font]

OS : Macosx 10.7.5
Xcode : 4.3.2

Hi,
thanks for your tips danielgm!

I can’t make it work neither.
I am in !0.8.4 & Xcode 4.6.3. (both up to date). I tried in 0.74 and 0.8 too without succes…
Do you know for which (0.74 or 0.8) github version is prepared?

I tried your steps putting out the examples from the ‘/addon/ofxFaceTracker’ folder.
Also I tried with base sdk 10.8 or 1.6; and also for deployment…

I didn’t tried the 2 lines you added on Build Settings…

Any tips someone?