Getting OF compiling on CentOS

I am trying to get OF compiling on the linux distribution CentOS so I can eventually get a headless application working on AWS. I ran install_dependecies.sh in the Fedora directory and the script ran, but was not able to find the following packages: openal-soft-devel, freeimage-devel, assimp-devel, rtaudio-devel

Unsurprisingly when I try to run compileOF.sh it doesn’t work with the following error:

I’ve been trying to get openAl installed by doing yum update and install, but it can’t find the package. I also tried downloading openal directly and using rpm -i to install it, but none of that had any effect. Any advice would be much appreciated.

Is it not one of these? https://pkgs.org/download/openal-soft-devel

That page lists all four packages for CentOS 6 and 7. I never used CentOS. Could it be that it’s configured to retrieve packages from an outdated mirror? You could maybe try changing the country where packages are retrieved from?

Thanks for the suggestion. Here is what ended up working incase anyone gets in the same situation:

sudo yum install epel-release
sudo yum install openal
download and install librtaudio
run the fedora install dependencies script

1 Like