fullscreen mode in linux with glut!!

It was so easy!

from the ubuntu forums:
http://ph.ubuntuforums.com/showthread.php?t=60967

You can put it full screen “manually” by assigning a keyboard shortcut.
Go to
System > Preferences > Keyboard shortcuts
then look for the section Window management > Toggle fullscreen Mode

I choose as was kind of conflicting with firefox.

You’ll need to choose the right size when creating the window in main.cpp but appart from that it works!

you are awesome. wow- i cant believe it was so easy! :slight_smile:

gracias cristina :wink:

It’s a little bit tricky because the window actually changes it’s dimensions and rotations and things like that change a little bit. Try with the VectorMath example to see what i mean…

I’m having a bit of trouble with linux fullscreen. The solution here does not seem to do anything for me. Assigning fullscreen with a shortcut does nothing to any window on my system. I’m using ubuntu 8.04…but I aslo run the newest version of compiz from source not the ubuntu package so that might be causing the problem.

Also whenever I try to run any on the example apps that can toggle fullscreen they also do not work. When toggling fullscreen in the examples they just maximize, but also they move themselves to a new viewport. Weird I know. So with compiz enabled if I toggle fullscreen the app disappears but shows up maximized on the cude face to the left of my current face.

Yes, fullscreen with linux doesn’t work, is a problem with glut and the window managers, but you can get fullscreen using OF_GAME_MODE instead of OF_FULLSCREEN.

I was trying the OF_GAME_MODE solution and I had this result in the Terminal:

game mode error: selected format(480x480:32@60) not available
freeglut (openframeworks): failed to change screen settings
freeglut (openframeworks): ERROR: Function called with no current window defined.

I suppose it is because the window dimensions I’ve supplied are not standard like 640*480 or 1024*768

yes, I tried 640*480 and 800*480 and gamemode works :wink:

i was working with chris sugrue the other night and we worked out how to get an app to go into fullscreen mode in ubuntu using the “wmctrl” program.

first you need to install it

  
apt-get install wmctrl  

then, in your “clickToLaunch” script, replace the last line of the script with this:

  
  
# the & symbol runs the app in the background  
./myApp_Debug &  
# wait for the window to open  
sleep 1  
# put the currently active window into fullscreen mode  
wmctrl -r :ACTIVE: -b add,fullscreen  
# wait for the app to die  
wait  
  

it’s slightly hacky but it seems to work.

in theory the code that wmctrl is executing could be put into the openframeworks library itself. the man page for wmctrl gives some hints about the call that is being made.

pix.

Actually, fullscreen will be windowing system specific from now on and not built into the OF core…GLUT will be abstracted out of OF in the 0.06 release.

Nice find though, and an interesting alternative for GLUT users!

EDIT:
wmctrl supports Compiz, which is a bonus.

Hi All,

thanks for nice tricks to go fullscreen with ubuntu. It all works very well for one screen.

Furthermore I want to go fullscreen with ubuntu with two screens and change back to OF_WINDOW in realtime.

At the moment I cant solve this problem.
If I use OF_GAME_MODE I cant change back to OF_WINDOW.
If I use OF_FULLSCREEN I cant go fullscreen over both two screen, but ubuntu cuts the fullscreen-window in the middle and only show one half on one of the screen.

What can I do?
Maybe there are few others with the same problem?!

,Seven